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Introduction
WXtoImgis fully automated weather satellite recording, decoding, editing, and viewing
software. WXtoImg supports map overlays, advanced colour enhancements, 3-D
images, animations, multi-pass images, projection transformation (e.g. Mercator), text
overlays, automated web page creation, temperature display, and control for many
weather satellite receivers, communications receivers, and scanners.

WXtoImgsupports both APT transmissions from polar orbiting satellites and WEFAX
transmissions from geostationary satellites.WXtoImghas a built in set of image pro-
cessing facilities, but can output raw images for further processing.Output is in JPEG,
PNG, BMP, PBM (PGM/PPM/PNM), or AVI format.

WXtoImgattempts to produce reasonable images from receivers which have too narrow
an IF bandwidth (e.g. scanners) although there are limitations on what can be done.

WXtoImguses the telemetry data on NOAA APT images to very accurately calibrate the
image, correct for non-linearities in signal strength, and make adjustments for gain
changes across the pass.The telemetry data is also used to calibrate the instruments to
provide for very accurate temperature readings.

On GOES satellites, the grayscale is used to correct for non-linearities in signal strength
and normalise the image. Accurate temperature calibration on IR images is also per-
formed.

On other satellites, the grayscale and black and white bars are used to adjust the gain.

WXtoImguses a PLL technique to correct for doppler shift and ensure straight images
on NOAA satellites even in the presence of very high noise levels or poor signal quality.
A burst cycle PLL is used on Meteor and Resurs satellites to correct for doppler shift
and to help ensure the images are straight.

Status and Information Lines
Across the top of the WXtoImg display are several tabs (Image, Audio Files, Raw
Images, and Saved Images). Upgradedversions will also have Composites, and Anima-
tions. Thefirst tab (Image), is WXtoImg’s main display. This is where decoded images
will be shown and where the image will be displayed while recording.All the other
tabs show thumbnails of audio files, raw images, saved images, or animations that were
created by WXtoImg. Note that images or audio files manually copied into WXtoImg
directories will not be shown. Clicking on a thumbnail will open the associated file.
This provides an easy means of reviewing a day’s (or week’s, or month’s) satellite
passes.

At the top of the WXtoImg Image screen, above the image, is the information line.
When an image is displayed, the information line will display the satellite name or type
and the date and time (in UTC) at which the image begins. For APT satellites, the satel-
lite direction of travel, maximum elevation (in degrees above the horizon) and azimuth
(E or W) at maximum elevation will be shown when available. For NOAA APT satel-
lites, the two channels will also be given. For WEFAX images, the digital header infor-
mation will also be given in parenthesis (when available).

At the bottom of the WXtoImg screen, below the image, are two status lines. The

version 2.10.10 1



WXTOIMG(GUI) WXTOIMG(GUI)

bottom line indicates the processing that is being performed, shows warnings and some-
times hints. The top status line is divided into a number of sections, the leftmost section
shows the current UTC time.To the right is the sub-information line, this usually shows
the satellite elevation and azimuth along with image coordinates under the cursor, but
while recording will show information about the recorded satellite’s location, and at cer-
tain times other information may be shown. Next, to the right, is that latitude and longi-
tude display -- when the cursor is over an image that has an associated overlay map this
will show the latitude and longitude (WGS84) under the cursor. Next is the distance
display, showing the distance from the ground station location to the location under the
cursor. Just to right of this is the temperature indication. When displaying NOAA or
GOES images, the temperature under the cursor is displayed in this section.The units
of temperature (C, F, or K) may be changed underGUI Optionsin the Optionsmenu.
To the right of the temperature indicator is the seconds into recording display. This
gives the number of seconds into the recording under the cursor. It is especially useful
when usingPartial Decodeto determine which part of a signal to decode. The right-
most section gives the volume used when decoding the image. During recording it
shows the volume. Normallythe receiver volume should be adjusted so the volume
shows between 50.0 and 75.0 (seeRequired Calibration under theHelp menu for more
details).

File Menu
This menu is used to select the file to decode and the filename when saving images.It
also is used to start the decode process.

Open Audio File...
Selects an audio file for subsequent decoding. Decoding will start automat-
ically as long asDisable auto-decodeis not selected in theOptions menu.
Audio input files may be in either AU (.au), WAVE (.wav), or raw (8-bit
unsigned or 16-bit signed LSB) format. The files must be encoded in linear
PCM format at 11025 samples per second. Either 8, 16, or 32 bits per sam-
ple is acceptable, but 8 bits per sample recordingsdo notcontain enough
information to produce good quality images.16 bits per sample is highly
recommended. Audiofiles should be mono.If a stereo (or multi channel)
audio file is used the program will ignore all but one channel. It is strongly
recommended that only mono audio files are used.

Open Raw Image...
WXtoImgcan read raw images inPNG, PBM (PGM), or NOA formats.
This considerably speeds up the processing time over reading in the audio
files. Decodingwill start automatically as long asDisable auto-decodeis
not selected in theOptions menu. NOA format files are produced by some
satellite receiving systems.These images should generally be 16 bit raw
grayscale images. Images inJPEG, BMP, AVI or other formats cannot be
read by WXtoImg. Note that theResync, Interpolate, and Disable PLL
options and the sampling rate settings have no affect when processing these
images. Thesesettings apply only when audio files are decoded.
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Save Image as...
Saves the currently displayed image. The output format (JPEG, PNG,
BMP, PNM, AVI) used for output is specified by the filename extension. If
you do not use an extension, or the extension does not relate to one of the
supported output formats, the default will be the format set in theImage
and Movie Options...under theOptions menu.

Composite Image to...
Saves the currently displayed image to the file given. If the current file
exists and you overwrite it, then (similar to the AVI transparency) the file
will be updated so that the original image will only be overwritten where
the current image contains valid satellite data. By selecting a projection
other thanNormal, and setting theProjection Optionsto a wide area around
your location, an image using multiple satellite passes may be built up.

Save Raw Image as...
Saves the 16 bit raw image in PNG format.Raw images are useful as they
can read usingOpen Raw Image...and can be processed to produce all the
different enhancements. Note that theResync, Interpolate, and Disable
PLL options and the sampling rate settings have no affect when processing
raw images.

Mixer Control...
Launches the mixer control used to select the input source, and recording
and monitoring volumes when recording.

Record... Starts the recording process.Allows selection of whether the image should
be decoded, and whether the audio file and/or raw image should be saved.
Also allows for a series of images or movies to be created. These settings
are also used for theAuto Processcommand. Theoptions for which
enhancements should be generated and the filenames for images and
movies can be set by clicking on the associated settings buttons. Seethe
Filename Templatesection for a description on how filenames are chosen.
Other aspects of the recording process (e.g. bits per sample) and whether
recording is squelch or satellite pass based can be changed underRecord-
ing Options... in theOptions menu. Therecording (and decoding) process
repeats until it is stopped by selectingStop from theFile menu. TheMini-
mum percent of projection filledsetting (upgraded versions only) disables
the saving of images and adding of movie frames where the resulting image
has less than the selected percent of pixels filled. Note that images are
never sav ed if the projection had no pixels filled. The default is 0.1%.The
Minimum solar elevation for visible images setting (upgraded versions
only) disables the saving of images which make use of visible light sensors
on the satellite and where the centre pass solar elevation is less than the set-
ting. Thedefault of 0 specifies that images should be saved reg ardless of
the solar elevation.
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Record only (show image if enabled)
Records satellites according to the settings inRecording
Optionsunder the options menu. An unprocessed image will
be shown while recording if enabled inGUI Options. Does not
perform additional processing.These recordings may be later
decoded by usingOpen Audio File under theFile menu or by
clicking on the thumbnail in theAudio Filestab.

Record and auto process
Records satellites according to the settings inRecording
Optionsunder the options menu.After recording, the audio is
decoded and displayed using the settings under theEnhance-
ments, Options and Projection menus. Anumber of options
can be enabled to create a set of images, add frames to anima-
tions, create composite images, and add images to web pages
(see FAQ for detailed information on creating web pages).
These settings are also used by theAuto Processcommand in
the File menu. Additionally, the audio file and/or the map file
(generated for map overlays) may be removed after processing
is complete.

Decode Starts the decode process.Decoding is automatically started after a file is
opened or the direction or enhancement is changed.The automatic decod-
ing may be disabled by selectingDisable auto-decodein the Options
menu. Manualstarting of the decode process is always required after any
options under theOptions menu have been changed, or when theSatellite
has been changed.

Partial Decode
Similar toDecodebut the cut start (how many seconds into the file to start
decoding) and cut end (how many seconds into the file to stop decoding)
may be specified.This is useful when a recording contains signals from
two or more satellites. It is also useful as a way to crop the image, by
decoding only the good portion of the image.When text overlays are
enabled, this has an advantage over using theCrop command from the
Image menu because text overlays will be correctly positioned in the final
image.

Auto Process
Builds and saves the images and adds frames to movies according to the
Recordsettings (under theFile menu). Notethat this processing will not
remove the audio nor map files even if those options are selected in the
record settings.

View Image...
Allows viewing of images. Files in PNG, JPEG, BMP or PBM
(PGM/PPM) format can be viewed. Theimage transformations under the
Imagemenu can be used to edit the images. Enhancements and options are
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not applicable to these images (useOpen Raw Image instead). Imagescan
be saved using theSave Image as... dialog under theFile menu. Inaddi-
tion, for images produced by WXtoImg, the image may be geometrically
transformed using the projections under theProjectionmenu.

View Movie...
Allows viewing of AVI animation.Under Windows, Direct X version 8.0
or above must be installed (note that for XP users Direct X will already be
installed). DirectX can be obtained from:

http://www.microsoft.com/directx

Under *NIX xanim must be installed to view the AVI movies. It can be
obtained from:

http://xanim.va.pubnix.com/home.html

Update Web Page
Manually publishes (via FTP) the current web page. This does not add an
image to the web page.It is useful whenAutomatically FTP as images are
addedis not selected inWeb Page SettingsunderRecordin theFile menu
and is typically used to transfer the web page manually over a dial-up Inter-
net connection. It can also be used to update the web page after making
changes to the template.

Re-upload Web Images
Forces all images associated with the web page to be re-uploaded to the
web site. Not required in normal use, this can be useful when publishing to
a new web server, or when all the images on the website were accidently
deleted.

Image Properties...
Displays a window showing information about the image being displayed.

Processing Info...
Displays a window showing all the information which appeared on the bot-
tom status line during the processing of the image.

Update Keplers
Uses the Internet to connect www.celestrak.com and download the latest
orbital elements for weather satellites.Orbital elements need to be updated
regularly to use the overlay and pass based recording options.Out-of-date
keplers will cause the registration on overlays to be significantly off. It is
recommended that the keplers be updated at least weekly if overlays are
being used.For very accurate overlay placement, daily or even twice daily
updates are recommended.

Pass List... Displays a list of satellite passes that are scheduled to be recorded from the
current time until the indicated time ahead (default 1 week). The pass list
displays only those satellites selected inActive APT Satellitesunder the
Optionsmenu. Itis also affected by theRecording Options.
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Clear Closes any image being viewed and clears the display. Note that WXtoImg
does not prompt to save the image since the image can be re-generated
from the original WAVE or raw image later.

Stop When recording or decoding, this stops the recording or decoding process
before it completes.

Exit,Quit Terminates the program. On MacOS X, theQuit command can be found
under theWXtoImgmenu.

Direction Menu
This menu is available only if expert mode is enabled (see Options -> GUI Options).
Sets the direction of the pass for polar orbiting satellites. This setting is ignored when
processing WEFAX images. The setting is also ignored if the map and projection sup-
port (GUI Optionsunder theOptionsmenu) is enabled since the program will determine
the direction.

Autodetect Uses the last modification time of the input file to make a guess at
which direction the satellite was traveling. This option will fail to
work correctly if the computers time zone is not set correctly, the
clock is off significantly, or if the station is too near to one of the
poles. Alsothis requires that the timestamp on the file represents the
time of the satellite pass.

South->North Northbound (ascending) pass. Satellite is moving from the south to
the north. In this case the image is rotated 180 degrees. For com-
bined NOAA APT images, the image is subsequently shifted 1/2 it’s
width so that the channel A and B images remain on their original
sides of the combined image.

North->South Southbound (descending) pass.Satellite is moving from the north to
the south.

Satellite Menu
Selects the satellite to decode. Under normal circumstances, for polar orbiting satel-
lites, this should be set toAutodetect APT. For geostationary satellites choose either
GOES, Meteosat, or GMS. Only in special circumstances (when receiver control is not
available and multiple satellites are overhead and the wrong satellite was recorded, or
when decoding old audio files created by other programs with inaccurate dates or
times), should the specific satellite be selected. The specific satellite options are avail-
able only if expert mode is enabled (see Options -> GUI Options).

Autodetect APT
Autodetect is limited to checking for APT images from polar orbiting satel-
lites. Thisspeeds up the detection process.

Meteosat Decodes WEFAX images from Meteosat geostationary satellites.

GOES Decodes WEFAX images from NOAA geostationary satellites (GOES).
GMSDecodes WEFAX images from GMS geostationary satellites.
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Autodetect Autodetect attempts to determine the satellite using signal and image pro-
cessing. Thisoption is available only if expert mode is enabled (see
Options -> GUI Options).

Autodetect WEFAX
Autodetect is limited to checking for WEFAX images from geostationary
satellites. It is much better to select the specific geostationary satellite
(GOES, Meteosat), rather than use this option.This option is available
only if expert mode is enabled (see Options -> GUI Options).

NOAA Decodes APT images from NOAA polar orbiting satellites (POES).This
option is available only if expert mode is enabled (see Options -> GUI
Options).

Meteor (series 3)
Decodes APT images from the Russian Meteor Series 3 satellites.This
option is available only if expert mode is enabled (see Options -> GUI
Options).

Meteor (series 2)
Decodes APT images from the Russian Meteor Series 2 satellites.This
option is available only if expert mode is enabled (see Options -> GUI
Options).

Resurs Decodes APT images from the Russian Resurs satellites.This option is
available only if expert mode is enabled (see Options -> GUI Options).

Okean Decodes APT images from the Russian Okean satellites.This option is
available only if expert mode is enabled (see Options -> GUI Options).

SICH Decodes APT images from the Russian SICH satellites.This option is
available only if expert mode is enabled (see Options -> GUI Options).

NOAA 12 Decodes APT images from NOAA polar orbiting satellites (POES) and sets
the sea surface temperature calibration to NOAA 12.If the Sea surface
temp enhancement is not being used, this option is equivalent to NOAA.
This option is available only if expert mode is enabled (see Options -> GUI
Options).

NOAA 14 Decodes APT images from NOAA polar orbiting satellites (POES) and sets
the sea surface temperature calibration to NOAA 14.If the Sea surface
temp enhancement is not being used, this option is equivalent to NOAA.
This option is available only if expert mode is enabled (see Options -> GUI
Options).

NOAA 15 Decodes APT images from NOAA polar orbiting satellites (POES) and sets
the sea surface temperature calibration to NOAA 15.If the Sea surface
temp enhancement is not being used, this option is equivalent to NOAA.
This option is available only if expert mode is enabled (see Options -> GUI
Options).
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NOAA 16 Decodes APT images from NOAA polar orbiting satellites (POES) and sets
the sea surface temperature calibration to NOAA 16.If the Sea surface
temp enhancement is not being used, this option is equivalent to NOAA.
This option is available only if expert mode is enabled (see Options -> GUI
Options).

NOAA 17 Decodes APT images from NOAA polar orbiting satellites (POES) and sets
the sea surface temperature calibration to NOAA 17.If the Sea surface
temp enhancement is not being used, this option is equivalent to NOAA.
This option is available only if expert mode is enabled (see Options -> GUI
Options).

NOAA 18 Decodes APT images from NOAA polar orbiting satellites (POES) and sets
the sea surface temperature calibration to NOAA 18.If the Sea surface
temp enhancement is not being used, this option is equivalent to NOAA.
This option is available only if expert mode is enabled (see Options -> GUI
Options).

NOAA 19 Decodes APT images from NOAA polar orbiting satellites (POES) and sets
the sea surface temperature calibration to NOAA 19.If the Sea surface
temp enhancement is not being used, this option is equivalent to NOAA.
This option is available only if expert mode is enabled (see Options -> GUI
Options).

Enhancements Menu
The Enhancementsmenu provides a wide range of enhancements. Changing the
enhancement will automatically start the decode process unlessDisable auto-decodeis
selected in theOptions menu.

Normal Produce a normal image, using Gamma, Sharpening, Despeckling,
etc settings.

Pristine Produce pristine output (best representation of original digital data).
Typically used to output images for further processing by other soft-
ware Pristine images are unenhanced, but unlike raw images have
been normalised to produce images which represent, as best as the
software is able to, the original digital data. No attempt is made to
temperature normalise IR images. Disables gamma, sharpening,
rotation, despeckling, and other enhancements.

Contrast enhance
Contrast enhancement is performed as per theContrastsetting in the
Optionsmenu.

Contrast enhance (NOAA ch A only)
Contrast enhancement is performed only on the NOAA channel A
image as per theContrastsetting in theOptionsmenu. Theother
image is not shown.
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Contrast enhance (NOAA ch B only)
Contrast enhancement is performed only on the NOAA channel B
image as per theContrastsetting in theOptionsmenu. Theother
image is not shown.

MCIR map colour IR (NOAA)
Colours the NOAA sensor 4 IR image using a map to colour the sea
blue and land green. High clouds appear white, lower clouds gray or
land/sea coloured, clouds generally appear lighter, but distinguishing
between land/sea and low cloud may be difficult. Darker colours
indicate warmer regions.

MSA Multispectral analysis (NOAA-# 2-4/1-4)
Multispectral analysis. Uses a NOAA channel 2-4 image and deter-
mines which regions are most likely to be cloud, land, or sea based
on an analysis of the two images. Producesa vivid false-coloured
image as a result. There are several options which affect colouring of
these images inImage and Movie Options...under theOptionsmenu.
This enhancement does not use a palette nor is it temperature nor-
malised.

MSA with precipitation (NOAA-# 2-4/1-4)
Same as MSA multispectral analysis, but high cold cloud tops are
coloured the same as the NO enhancement to give an approximate
indication of the probability and intensity of precipitation.

MSA anaglyph false 3-D (NOAA-# 2-4/1-4)
Same as MSA multispectral analysis, but creates a 3-D anaglyph
image (must be viewed with red/blue glasses). Operational only if
the software has been upgraded.

HVCT false-colour (NOAA 2-4)
Similar to HVC (below), but with blue water and with colours more
indicative of land temperatures.

HVCT with precipitation (NOAA 2-4)
Same as HVCT false-colour, but high cold cloud tops are coloured
the same as the NO enhancement to give an approximate indication
of the probability and intensity of precipitation.

HVC false-colour (NOAA 2-4)
Creates a false colour image from NOAA APT images based on tem-
perature using the HVC colour model.Uses the temperature derived
from the sensor 4 image to select the hue and the brightness from the
visible (sensor 2) image (or the sensor 4 image if theUse other sen-
sor option is selected) to select the value and chroma. The HVC
colour model attempts to ensure that different colours at the same
value will appear to the eye to be the same brightness and the spacing
between colours representing each degree will appear to the eye to be
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similar. Bright areas are completely unsaturated in this model.

Sea surface temp (NOAA)
Creates a false colour image from NOAA APT images based on sea
surface temperature. Uses the sea surface temperature derived from
just the sensor 4 image to colour the image. Land appears black and
cold high cloud will also appear black. The sea surface temperature
may be incorrect due to the presence of low cloud, or of thin or small
clouds in the pixel evaluated, or from noise in the signal.

Thermal (NOAA)Produces a false colour image from NOAA APT images based on
temperature. Provides a good way of visualising cloud temperatures.

Ve getation (NOAA 1-2)
Requires the rarely available NOAA APT sensor 1 and 2 images
(seen during the test phase after satellite launch).A vegetative index
is built up and this is used so that land will be coloured green, water
dark blue, and clouds white. No palette is used for this enhancement
and the output is not temperature normalised.

Anaglyph false 3-D (GOES/NOAA)
Creates a false 3-D image (must be viewed with red/blue glasses) of
the visible (sensor 2) image (or the sensor 4 image if no visible
image is available) by estimating cloud height. Operational only if
the software has been upgraded.

Colour anaglyph false 3-D (NOAA)
Creates a false colour 3-D image based on the HVCT enhancement
(must be viewed with red/blue glasses) using the visible and far-IR
images of the NOAA satellite (or just the far-IR image if no visible
image is available). Operationalonly if the software has been
upgraded.

Class enhancement (NOAA)
Unsupervised classification of NOAA APT images using an iterative
optimisation clustering algorithm. Uses an initial 27 cluster centres
spaced equally along the two-dimensional diagonal. The classifica-
tion is used to tint the histogram equalised channel A image.

NO colour IR enhancement (GOES/NOAA)
NOAA colour IR contrast enhancement option.Greatly increases
contrast in the darker land/sea regions and colours the cold cloud
tops. Allows fine detail in land and sea to be seen and provides a
very readable indication of cloud top temperatures. This enhance-
ment option is temperature normalised.

ZA general IR enhancement (GOES/NOAA)
NOAA general purpose meteorological IR enhancement option.
Increases contrast by saturating the very low and very high tempera-
ture regions where there is typically very little information.This
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enhancement option is temperature normalised.

MB thunderstorm (GOES/NOAA)
NOAA cold cloud top enhancement option.Useful for showing
where the strongest rainfall is occurring in thunderstorms.This
enhancement option is temperature normalised.

MD warm season MB (GOES/NOAA)
The NOAA MD enhancement is a modification of the popular, gen-
eral use MB enhancement scheme. It is intended for warm season
use, and provides improved enhancement within the gray "step
wedges" that depict "warm top" convection. An additional
improvement is better delineation of warm low clouds (30C to 7C).
The middle cloud range is somewhat broader than the MB, and
enhancement of details is minimised.Otherwise, it is the same as the
MB enhancement.This enhancement option is temperature nor-
malised.

BD hurricane (GOES/NOAA)
NOAA hurricane enhancement option. Highlights certain tempera-
tures in the eye and eye wall of the storm system which are known to
be related to the intensity of the hurricane.This enhancement option
is temperature normalised.

CC enhancement (GOES/NOAA)
NOAA CC enhancement curve. Thisenhancement option is temper-
ature normalised. This option is available only if expert mode is
enabled (see Options -> GUI Options).

EC enhancement (GOES/NOAA)
NOAA EC enhancement curve. Thisenhancement option is temper-
ature normalised. This option is available only if expert mode is
enabled (see Options -> GUI Options).

HE western US (GOES/NOAA)
The NOAA HE enhancement is used principally by weather offices
in the western United States.It provides good enhancement of a
wide variety of cloud types, but is somewhat complex, and may be
difficult to use at first. It enhances low and middle level clouds com-
mon along the Pacific Coast of North America in two separate gray
shade ranges. The freezing level is easily determined, an advantage
for aviation users concerned with icing.Step wedge regions display
very cold infrared cloud top temperatures associated with thunder-
storms and frontal systems in 5 degree increments down to -60 C.
Tw o additional "repeat gray" segments define cloud top temperatures
colder than -60C. This enhancement option is temperature nor-
malised. Thisoption is available only if expert mode is enabled (see
Options -> GUI Options).
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HF new western US (GOES/NOAA)
The NOAA HF enhancement is the most current of the "H" series of
enhancements, and is used principally by weather offices in the west-
ern United States. It provides good enhancement of low and middle
level clouds common along the Pacific Coast of North America.Step
wedge regions display very cold infrared cloud top temperatures
associated with thunderstorms and frontal systems in 5 degree incre-
ments down to -60 C.Tw o additional "repeat gray" segments define
cloud top temperatures colder than -60C. This enhancement option
is temperature normalised. This option is available only if expert
mode is enabled (see Options -> GUI Options).

JF simple sea surface/cold cloud (GOES/NOAA)
The NOAA JF enhancement is a hybrid enhancement scheme used to
highlight both sea surface temperatures, and cold cloud tops associ-
ated with thunderstorms and other weather systems.It is somewhat
simpler to interpret than the later JJ enhancement. The coldest por-
tion of the enhancement (less than -33C) is nearly identical to the
general-use MB enhancement. Maximum enhancement is provided
at the warm end (25 to 10C) to depict sea surface temperatures and
warm low clouds in tropical and sub-tropical areas. This enhance-
ment option is temperature normalised. This option is available only
if expert mode is enabled (see Options -> GUI Options).

JJ sea surface/cold cloud (GOES/NOAA)
The NOAA JJ enhancement is used to highlight both sea surface tem-
peratures, and cold cloud tops associated with thunderstorms and
other weather systems.Maximum enhancement is provided at the
warm end (23 to 0C) to depict sea surface temperatures and low
clouds. Thepresence of a freezing level break point is important for
aviation users interested in icing conditions.Multiple, steep, ramp
enhancement ranges provide considerable detail within cold cloud
tops such as thunderstorms, but it is difficult to determine the actual
temperatures with any accuracy. This enhancement option is temper-
ature normalised. This option is available only if expert mode is
enabled (see Options -> GUI Options).

LC fog/low cloud/precip (GOES)
The NOAA LC curve is used on images from the 3.9 micron short-
wave infrared channel (CH2) of GOES.It provides maximum
enhancement in the temperature range where fog and low clouds typ-
ically occur (36C to -9C).Another enhanced thermal range is from
-10C to -29C, the region of precipitation generation in mid-latitude
weather systems. Since CH2 is sensitive to "hot spots," a steep,
reverse ramp is found at the warm end (68C to 50C) to show any
observable fires as white.There is no enhancement at the very cold
end (-30 to -67C), due to the instrument noise normally present at
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these temperatures.This enhancement option is temperature nor-
malised. Thisoption is available only if expert mode is enabled (see
Options -> GUI Options).

TA enhancement (GOES/NOAA)
NOAA TA enhancement curve. Thisenhancement option is temper-
ature normalised.This option is available only if expert mode is
enabled (see Options -> GUI Options).

WV water vapour (GOES)
The modified NOAA WV curve is used for the 6.7 micron water
vapor channel (CH3) on GOES. The only temperature range that is
enhanced is between -5C and -90C.Temperatures colder than -90C
are shown as white, and temperatures warmer than -5C are displayed
as black. This enhancement option is temperature normalised.This
option is available only if expert mode is enabled (see Options ->
GUI Options).

Options Menu
Selects a variety of options. The factory default settings for all the on/off options in this
menu is off. For Gamma, Sharpen, Despeckle, etc.the factory default setting is indi-
cated by an asterisk; a plus indicates an alternative recommended setting.

Disable auto-decode
If selected, this option prevents WXtoImg from starting an automatic
decode whenever the enhancement or direction is changed.

Interpolate If selected, enables interpolate and oversample (50% larger images).Cre-
ates larger images by increasing the sampling rate in the horizontal and
interpolation in the vertical. In the case of NOAA images the Channel B
image is also shifted down to compensate for the satellite movement and
the sampling method.This provides better registration between the images
and thus improves image quality in multispectral transformations.This
option is available only if expert mode is enabled (see Options -> GUI
Options).

Use other sensor
The HVC and HVCT enahancements normally require one of the channels
to be a visible light sensor. By setting this option, the enhancement will
make use of the far-IR sensor when no visible sensor is available.

Disable PLL
If selected, disables the phase locked loop code used to ensure the image is
not bent due to doppler-shift nor slanted due to slight variations in sampling
rate. Thisoption is sometimes useful with recordings from scanners to dis-
able the burst PLL on Meteor and Resurs satellites which can cause prob-
lems when decoding very poor quality signals.

Show All If selected, disables the normal cropping of noisy/low signal portions of the
image. SeealsoCrop telemetrywhich crops the sides of the image.
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Crop telemetry
If selected, crops the telemetry lines from the sides of the image.See also
Show Allwhich disables the automatic cropping of the top and bottom of
the image.

Resync If selected, enables attempts to resync image. If enabledWXtoImgattempts
to correct for stair-stepped/split images caused by missing time in the input
audio file, however with low S/N ratios or from recordings made by too
narrow IF bandwidth receivers (scanners), this may cause false corrections
to be made resulting in very broken images.

Disable Map Overlay
If selected, disables the overlaying of maps on the image.Overlaying maps
requires the keplers to be up-to-date.SeeUpdate Keplersin theFile menu.
Disabling map overlays does not disable map generation.SeeEnable map
and projection supportin GUI Options.

Noise filter If selected, enables the noise filter. This is a 5x5 median edge-preserving
image filter. Causes significant blurring of the image. This option is avail-
able only if expert mode is enabled (see Options -> GUI Options).

Contrast Allows selection of the contrast enhancement used within the HVC, HVCT,
MSA, and veg enhancements. Operationalonly if the software has been
upgraded. Selecteither Hist Eq for histogram equalisation,Linear (con-
stant)for a constant linear enhancement which varies only according to the
satellite sensor, Linear (variable)for variable linear enhancement which is
adjusted for every image, orNoneto disable any contrast enhancement.If
images are going to be later compared or combined than eitherLinear (con-
stant)or Noneshould be used as all images are treated in exactly the same
way with these options.

Illumination Compensation
Illumination compensation corrects for the uneven lighting of the earth’s
surface by the sun. Full compensation corrects each image so that the
earth’s surface appears to be lit from directly overhead. High,Med and
Low compensation apply some compensation, but do not fully correct.
None performs no compensation.Note that with low sun angles compensa-
tion can dramatically increase the effects of noise in the signal.

Gamma The default gamma correction to apply. Typically between 1.00 and 2.50.
A value of 1.00 disables gamma correction.For PC displays a gamma of
about 1.40 seems to be optimal for viewing, for Macintosh systems 1.15,
for SGI systems 1.10, for NeXT systems 1.00, and for Sun and other sys-
tems 1.40 is recommended.

Sharpen Set sharpening factor. The default is 0.6.

Despeckle Enables removing of random noise in the image. If expert mode is enabled
(see Options -> GUI Options), then the despeckling threshold may be set.
To disable despeckling usenone. The threshold is the number of standard
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deviations the pixel in question can vary from the mean of the other pixels
in a 5x5 area surrounding it before it is considered noise and is replaced by
the mean value. Increasingsigma decreases the number of pixels which
will be replaced, decreasing sigma increases the number of pixels which
will be replaced. The default isnone, a value of 2.0 is recommended in
most circumstances (this is the value used if despeckle is enabled in non-
expert mode). Lower values will cause significant blurring of the image.

Active APT Satellites
Allows selection of the active APT satellites. The Active APT Satellites
dialog controls which satellites maps may be created for and which satel-
lites will be recorded if theRecord only when active APT satellites are
overheadoption is checked in theRecording Optionsdialog. Alsoallows
setting of the satellite frequency (MHz) used when control of the receiver’s
channel is enabled.A priority can also be set. When two or more satellites
are overhead then the satellite with the highest priority (1=highest, 5=low-
est) will be recorded.If the satellites have the same priority, then the satel-
lite with the highest maximum elevation will be recorded. Priority has no
effect if receiver control is not enabled in theRecording Options. If Update
this table when updating Keplers is selected, then the software will select
the active satellites and set their frequencies (priorities will not be changed)
according to the currently active satellites (downloaded via the Internet).
EnablingExpert modein GUI Optionsallows no longer transmitting satel-
lites to be selected.

Ground Station Location
Allows setting of the ground station location. Latitude and longitude
should be entered in degrees and fractions of degrees and not in degrees,
minutes, and seconds (north and east should be entered as positive num-
bers, south and west should be entered as negative numbers). Ifyou enter
the name of a large city (population 100,000 or more) and the country (e.g.
United States, United Kingdom), you can set the latitude and longitude
automatically by clicking theLookup Lat/Lonbutton. Thismust be set if
map overlays are being used or if theRecord only when active APT satel-
lites are overheadoption is checked in theRecording Optionsdialog.
Alternatively, you can check theUse GPSbox, and set the serial port the
GPS is connected to.You must also set the baud rate (use 4800 if unsure).
On your GPS you will have to enable NMEA output (at the same baud rate)
as this will not be enabled by default. Checkthe GPS manual for instruc-
tions on how to do this. TheGPS must support NMEA 2.x. While this
option is enabled, WXtoImg will check the GPS for position information
when needed. The GPS option is available only on upgraded copies. The
GPS requires GGA, RMC or GLL NMEA sentances to be output by the
GPS. Setting time is only available if an RMC or GLL sentance is avail-
able. You can also keep the PC clock set using the GPS by checking the
Set PC clock from GPSbox. Notethat WXtoImg uses WGS84 datum for
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position, projections, and map overlays. OnLinux and Mac OS X you’ll
have to run the command/usr/sbin/visudoas root and add a line to the bot-
tom similar to myusername myhostname= NOPASSWD: /bin/date.
Where myusername is your user name and myhostname is the computer’s
hostname (runhostnameto get the hostname if unsure).

Internet Options...
WXtoImg requires up-to-date Keplers to build map overlays and predict
satellite passes.You can choose to obtain the Keplers from Celestrak or
Space Track. Celestrakonly has a temporary permit to distribute Keplers,
so it is highly recommended that a username and password from Space
Track is obtained from:

http://www.space-track.org/

Once you receive your password, you will need to login to the Space Track
website and change your temporary password, then selectGet Keplers from
Space Trackand enter your username and password.

On Windows XP and Windows Server 2003, you can configure the Internet
time server settings. Enabling this will ensure maps are aligned accurately.

Recording Options...
Used to select the recording mode and options.

Record using WEFAX start/stop tones (for geostationary satellites on 1.6GHz)
If selected then recording starts when the WEFAX start signal
from a geostationary satellite (i.e. GOES, Meteosat, or GMS)
is hear. Recording stops when the WEFAX stop signal is
heard.

Record only when active APT satellites are overhead
If selected, then recording occurs only when a satellite is pass-
ing overhead which is selected in theActive APT Satellites
dialog in theOptions menu and also meets the conditions
below. This is the default. This recording mode is the most
efficient and uses the least CPU since it does not need to con-
tinuously decode the audio signal.

with maximum elevation above (degrees)
Only satellites where the maximum elevation (above the hori-
zon) is equal to or better that the value here will be recorded.
The factory default is 20.

record only when satellite is above (degrees)
Waits until the satellite is above the horizon by this number of
degrees before recording and stops recording when the satellite
falls below this number of degrees. Thefactory default is 8.

and require Allows an optional additional check before recording is started.
If squelch break is selected then the program waits for the vol-
ume to rise above the sound trigger level before recording.If
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2400Hz carrieris selected then then the program waits for a
2400 Hz carrier to be detected before recording starts. If either
of these options is selected then thefinish recording delayis
also used, but recording will stop earlier if the satellite falls
below the value set inrecord only when satellite is above. If
nothing is selected, then the program will record while the
satellite is overhead whether a signal is detected or not.The
factory default is2400Hz carrier.

soundcard Allows selection which soundcard should be used for record-
ing. Default on Linux is "/dev/dsp" (additional soundcards are
named "/dev/dsp1", "/dev/dsp2", etc.). On DOS and Windows
the default is the first soundcard. On the Mac, the default is the
Mac’s default soundcard.

sample bits Allows selection of 8 or 16 bit recordings.16-bit recordings
produce the best quality images, but 8-bit recordings reduce
the size of the recordings by half.16 bit recordings are highly
recommended. Thefactory default is 16. This option can only
be changed if expert mode is enabled (see Options -> GUI
Options).

antenna type Antenna type.

receiver type Setting for computer control of receiver channel. Setto noneif
the receiver does not support computer control or is not con-
nected to the computer. Control only occurs if the recording
mode is set toRecord only when active APT satellites are over-
head. If using PCR1000, ensure you have set the PCR1000’s
internal jumper for line out as discussed in the PCR1000 man-
ual before using this control. Alternatively you may use the
PCR100 setting for the PCR1000 which assumes speaker-level
output. The PCR1500 setting disables the speaker and
assumes the soundcard is set to pickup input from the PCR
USB Audio Device. Kenwood receiver control operates at
4800 baud default. AR3000,AR5000, and AOR receiver con-
trol operates at 4800 baud default. BC245XLT, BC895XLT
and BC780XLT receiver control operates at 9600 baud default.
The PSR-500 is supported only on Windows and you should
set "DG INT PRIME" to 1 to prevent dropouts during recep-
tion. IC-R8500 and IC-R10 use 9600 baud default and
addresses 4A and 52 respectively. Use External to run the
external command wxctl (wxctl, wxctl.com, wxctl.exe, or
wxctl.bat) for control (passed the satellite name as argument 1,
the frequency in MHz as argument 2, and the receiver port as
argument 3; satellite name will be an empty string and fre-
quency will be 0.00 when no channel is selected -- generally
the control program should enter scan mode but this is
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optional).

receiver port The RS-232 port used for computer control of the receiver
channel. Ifthe control is not via RS-232 (e.g. the game port)
this setting is ignored.

receiver baud Sets the baud rate to communicate with the receiver. If the
receiver baud rate cannot be changed, this setting will have no
effect. Usereceiver defaultto select the default baud rate for
the receiver.

Auto Processing Options...
Used to select the options for automatic generation of images, composite
images, movies (animations), and web page creation.SeeRecordunder the
File menu (which contains the same options) for details.

Map Overlay Options...
Allows selection of which features and what colours they appear on
the map overlays.

Text Options...
Allows text to be displayed on the image. Operational only if the
software has been upgraded. There are two text areas. To enable
either or both select the associated Enable box. The text may contain
percent sequences that will be expanded as described in Filename
Template below. The colour may selected from the list and the
default size (in points) selected from the list. The position on the
image may be specified using X: and Y:. The value may be c for cen-
tre, or a positive number for the number of pixels from the left or top
edge, or a negative number for the number of pixels from the right
or bottom edge. The text box can contain multiple lines. A line can
start with fontsize=##, to set a different font size (in points) for the
line and any subsequent lines. The TrueType Font allows the selec-
tion of an alternative true type font. Leave this blank to use the sup-
plied font. An alternative font can be used to provide text overlays
for European and Asian languages as the built-in font supports only
the standard ASCII (English) characters.

Projection Options...
Allows for the control of projections. Operational only if the soft-
ware has been upgraded.

Reference Latitude
The map projection will be centered at this latitude. Use
negative numbers for south, positive for north. Note that
this is not the centre of the image but the centre of the
projection itself (if in doubt leave this field blank).
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Reference Longitude
The map projection will be centered at this longitude.
Use negative numbers for west, positive for east. Note
that this is not the centre of the image but the centre of
the projection itself (if in doubt leave this field blank).

North Boundary (latitude)

South Boundary (latitude)
If the boundaries are specified then the resulting image
will will be cut off at these boundaries and will not show
points outside. Will not function unless all four bound-
aries are given. Use negative numbers for southern
hemisphere. Should be between 90.0 and -90.0.

West Boundary (longitude)

East Boundary (longitude)
If the boundaries are specified then the resulting image
will will be cut off at these boundaries and will not show
points outside. Will not function unless all four bound-
aries are given. Use negative numbers for west, positive
for east. Should be between -180.0 and 180.0.

Scale (norm 1.0) or output width
Sets the scale or output width for the projection. Scale is
a relative value which defaults to 1.0. A value of 0.5 will
result in an image half the width and half the height. A
value of 2.0 will result in an image twice as wide and
twice as high. There is no best value, but large or small
values may result in a loss of image quality. Values
greater than 50 are assumed to be the required output
width in pixels (rather than a relative scale). Values of
scale greater than 2.0 are not supported, and values for
output width less than 50 are not supported.

Sampling Frequency...
This option is available only if expert mode is enabled (see Options
-> GUI Options). Sampling rates can be much more easily and accu-
rately set using Slant Correction in the Image menu. Allows manual
setting of the sample rate. Try varying the sample rate from the nor-
mal by 5 samples per second at a time (so if you have 11025 samples
per second audio files try, 11020, 11030, 11015, 11035, 11010, 11040,
etc) until the image is reasonably vertical, then adjust by 1 or 2 sam-
ples per second until the PLL locks and the image becomes exactly
vertical. Determination of the sound cards sample rate normally
needs to be done only once. A setting of 0.0 indicates that the
default sample rate should be used.
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Image and Movie Options...
Used to set a variety of options relating to image and AVI output.

Default Image Format
Set the default image format to one of JPEG, PNG, BMP,
PBM (PGM/PPM/PNM), or AVI. This is used when
auto saving images. Normally, WXtoImg uses the file-
name extension (one of .png, .bmp, .pbm, .pgm, .ppm,
.pnm, .jpg, .jpeg, or .avi in lower or upper case) to deter-
mine the output file type, when the Save Image as... item
from the File menu is selected. If the output file exten-
sion is not specified or the output extension does not
indicate a known format, then the default image format
is used to set the file type.

Default for Anaglyphs
Set the default image format for anaglyphs to one of
JPEG, PNG, BMP, PBM (PGM/PPM/PNM). This is used
when auto saving images. Note that anaglyphs are best
saved in a lossless image format (PNG, BMP, or PPM) as
the colour shifts caused by JPEG encoding can affect 3-D
viewing.

Default for Composites
Set the default image format for composite images to one
of JPEG, PNG, BMP, PBM (PGM/PPM/PNM). This is
used when auto saving images. Note that composite
images are best saved in a lossless image format (PNG,
BMP, or PPM) because multiple overlaying of the com-
posite image can compound the loss of image quality
inherent in JPEG images.

JPEG Quality Sets the quality for JPEG images. The factory default is
65. The valid range is 0 to 100. See Image Output For-
mats for discussion.

HVC Palette Allows selection of the palette for the HVC enhancement.
PNG, BMP and PPM format files are supported. See the
-P option in the wxtoimg command line manual for the
technical details. If left blank, then the default HVC
palette is used.

Thermal Palette Allows selection of the palette for the Thermal enhance-
ment. PNG, BMP and PPM format files are supported.
See the -P option in the wxtoimg command line manual
for the technical details. If left blank, then the default
Thermal palette is used.
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Sea Surface Temp Palette
Allows selection of the palette for the Sea Surface Tem-
perature enhancement. PNG, BMP and PPM format files
are supported. See the -P option in the wxtoimg com-
mand line manual for the technical details. If left blank,
then the default Sea Surface Temp Palette is used.

MSA Sea to Land
It is highly recommended that you do not change this
option. Multispectral analysis sea to land adjustment.
The factory default value is 50. This should be decreased
if land in multispectral analysis enhancements appears
blue, and increased if water appears green. The valid
range is 0 to 100. This option is available only if expert
mode is enabled (see Options -> GUI Options) and
should really never be changed.

MSA Land to Cloud
It is highly recommended that you do not change this
option. Multispectral analysis land to cloud adjustment.
The factory default value is 50. This should be decreased
if cloud in multispectral analysis enhancements appears
green and increased if land appears gray or white. The
valid range is 0 to 100. This option is available only if
expert mode is enabled (see Options -> GUI Options)
and should really never be changed.

AVI Codec The compression method to use for AVI animations.
Currently three types are supported: MJPG, JPEG, and
RGB. MJPG (Motion JPEG) provides for excellent com-
pression, JPEG provides somewhat less compression
(and may be less standardised), RGB does no compres-
sion at all. Under BeOS JPEG is recommended (as there
are no available MJPG decoders), under all other operat-
ing systems MJPG is the recommended choice (MJPG
decoders for Windows are available in the DirectX pack-
age). The JPGQ and lJPGS codecs are provided for back-
ward compatibility and will be dropped in a future
release.

AVI Transparency
Enables transparency on AVI images so that if the pixels
in the current frame are not set the pixels from the previ-
ous frame will be used. Better results may be achieved
by increasing the AVI Quality or using the RGB AVI
Codec. The factory default is enabled.
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AVI Quality Sets the quality for AVI animations. The factory default
is 20. The valid range is 0 to 100. See Image Output For-
mats for discussion.

AVI Max Frames
The maximum number of frames in the animation. If,
after adding the new image, the number of frames in the
animation exceeds this number then frames will be
dropped from the beginning so that the total number of
frames is AVI Max Frames.

AVI Frame Rate The rate at which to display the animation in frames/sec-
ond. Normally values between 0.2 (1 frame every 5 sec-
onds) and 8.0 (8 frames per second) are useful. The fac-
tory default is 1.0.

AVI Scale Reduce output animations by fact factor. Factor should
be between 0.0 and 1.0. The factory default is 0.5.

File Names and Locations...
Sets the locations for opening and saving files.

Audio file naming
Audio file names are the time of the recording. You can
change audio file name format to some other time for-
mat. Beware that this setting also affects how WXtoImg
determines when a file was recorded. Selecting Other
will prevent WXtoImg from using the filename to deter-
mine the time of recording (and audio files will be
recorded as MMDDHHMM UTC time.

Filename Template
Used to define the default output filename, and the file-
name for raw files used when recording. If left blank,
then this defaults to the input filename or when record-
ing to %T. See Filename Template section for details.

Use for audio recordings/maps too
If selected, the audio recordings and any overlay maps
will be renamed to match the template after decoding.
Note that if a no decode option is selected when record-
ing then the audio recordings/maps will not be renamed
to use the the template.

Audio File Location
The folder/directory in which audio files will be saved
when recording/decoding. Also the default location
when opening audio files.
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Raw Image Location
The folder/directory in which raw images will be saved
when recording. Also the default location when open-
ing/saving raw images.

Save Image Location
The default location when saving processed/enhanced
images using the Save Image as... option under the File
menu.

Map File Location
The folder/directory in which map files will be saved
when recording/decoding.

Thumbnail Location
The folder/directory in which thumbnail images will be
saved.

GUI Options...
Allows setting of operations that affect the graphical user interface
(GUI).

Temperature units
When temperature is shown, this indicates what units
should be used. Degrees Celsius, Fahrenheit, or Kelvin
may be chosen. The factory default is Celsius.

Distance units Allows the selection of miles (mi), nautical miles (nm), or
kilimoters (km) where WXtoImg shows distances. The
factory default is km.

Help Language Select EN (English), ES (Spanish), DE (German), JA
(Japanese), or PL (Polish) for the help language. Transla-
tions for most languages are not yet available. If you can
help in translation for any of these or other languages
contact us at http://www.wxtoimg.com/email.html .

Help Font Size Allows the font size for help text to be made larger or
smaller. +0 is the default size, negative numbers use
smaller than normal fonts, positive numbers larger than
normal fonts.

Date/time format Allows selection of the date and time format where
WXtoImg displays dates and times. Operational only if
the software has been upgraded.

Show time as UTC
If enabled times will be shown in UTC, if disabled, local
time will be shown. Operational only if the software has
been upgraded.
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Enable map and projection support
By default this is enabled, but on very slow processors
disabling this can speed up image generation by dis-
abling support for map overlays, projections, good qual-
ity MSA (multi spectral analysis enhancements), MCIR
enhancements, and illumination compensation. Because
of the significant impact on the use of MSA and MCIR
enhancements and on other WXtoImg features, it is
strongly recommended that this feature be left enabled.
This option is available only if expert mode is enabled
(see Options -> GUI Options).

Flip Meteor series 3 images
If selected then images from Meteor series 3 will be auto-
matically flipped. This is useful if map and projection
support is disabled and Meteor 3 is in a phase where all
the images are being presented upside down. The fac-
tory default is off. This option is available only if expert
mode is enabled (see Options -> GUI Options) and is of
little use since the failure of Meteor 3-21.

Use private colormap
If the display has only 256 Colors (8 bit), then when this
is selected (the factory default) a new colormap will be
installed. This provides for the full 256 colours to be
used by WXtoImg itself (instead of being shared with all
other applications and the operating system). This set-
ting should have no effect on High Color (15 or 16 bit) or
Tr ue Color (24 or 32 bit) adapters. The options must be
saved and the program exited and restarted before any
change will take effect. This option is available only if
expert mode is enabled (see Options -> GUI Options).

Tear off menus If enabled, then next time program is started menus can
be torn from the application (by selecting the dashed line
at the top of the menu). This will place the menu in a
separate window which can be moved around the
screen. This allows for easier selection of enhancements
and options. Operational on Windows and Linux plat-
forms only and only if the software has been upgraded.

Status info text size
Allows you to change the size of the text on the status
lines at the bottom of the main window and the info line
above the main image. The default is Normal. This
options is only available on Windows platforms.
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Automatically enter record mode
If selected then when WXtoImg will automatically enter
record mode as though Record had been selected from the
File menu and Record had been clicked. For APT satel-
lites, record mode is entered a few minutes before the
next satellite pass and exited after processing is com-
plete. This mode is also useful to automate record-
ing/decoding when WXtoImg is started automatically.
Operational only if the software has been upgraded.

Disable sat position during record
Disables satellite position (elevation and azimuth) calcu-
lations and display while recording a satellite passing
overhead. This may be useful on slow computers to help
prevent breaks in the image caused by missing time in
the recording.

Automatically update Keplers
If selected, then Keplers will be downloaded via the
Internet approximately every 24 hours. Requires an
"always-on", or automatic connection to the Internet.
Operational only if the software has been upgraded and
if WXtoImg is being used to record.

Auto-save options on exit
If selected then all options will be saved as if Save Options
had be chosen just prior to exiting the program. The fac-
tory default is on.

Maximum number of thumbnails
Sets the maximum number of thumbnails that can be dis-
played on any of the thumbnail pages. The most recent
thumbnails are shown.

Enable Expert Mode
Enabled a set of mostly historical features, many of
which have little use. Options must be saved and the
program exited and restarted before changes take effect.

Save Options
This saves all the options on the options menu (and options dialogs
on the options menu) and with the exception of Interpolate, Show
All, Resync, and Disable PLL. This option also saves the window
size and position. Also the recording modes and image and movie
settings are saved. If this menu item is not chosen, then any changes
made will not be restored when the program is restarted (unless
Auto-save options on exit is selected in the GUI Options dialog).
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Projection Menu
The Projection menu supports changing the map projection used to display the
APT satellite image. The default normal projection is the unaltered space
oblique projection the satellite provides.

Normal The unaltered space oblique projection that the satellite provides.

Mercator The classic Mercator projection. Lines of constant direction (rhumb
lines) appear straight. This cylindrical projection does not work at
or near the poles, and displays considerable area distortion away
from the equator.

Equidistant Cylindrical
An equidistant cylindrical projection where the lines of latitude and
longitude are parallel and equally spaced. Sometimes called Plate
Carree. Displays considerable area distortion near the poles.

Equal-Area Cylindrical
An cylindrical projection where land masses of equal area have the
same area. Displays considerable shape distortion near the poles.

Eckert IV An equal-area projection with semi-circle meridians used for world
maps.

Eckert VI An equal-area projection with sinusoidal meridians used for world
maps.

Mollweide Another equal-area projection commonly used for world maps.

Miller A compromise cylindrical projection which shows less distortion
than the Mercator but does not show straight rhumb lines.

Polar Lambert Equal-Area
The Polar Lambert Azimuthal Equal-Area projection. An azimuthal
projection similar to the Polar Stereographic but which is equal area.

Polar Stereographic
An azimuthal projection where the lines of longitude converge at the
poles.

Polar Azimuthal Equidistant
An equidistant projection centered at the poles.

Orthographic
A perspective projection from infinite distance.

Image Menu
Options which use the image or allow the image to be hand altered after pro-
cessing.

Slant Correction...
After selection, a line may be dragged along a vertical edge to set the
sampling rate. See the Required Calibration... document under the
Help menu for more details.
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Move Map Overlay...
After selection a line may be dragged between a point on the over-
lay and the corresponding point on the image to adjust the position
of the overlay.

Colour Negative
Creates a colour negative of the image. For grayscale images, black
becomes white and white black.

Warmer Colours
Warms the colours in the image by shifting the image toward the red
end of the spectrum. The effects can be quite subtle, so the com-
mand may have to be repeated before the effect becomes noticeable.

Colder Colours
Cools the colours in the image by shifting the image to-wards the
blue end of the spectrum. The effects can be quite subtle, so the
command may have to be repeated before the effect becomes notice-
able.

Convert to Grayscale
Converts the image to a grayscale image.

Histogram Equalise Image
The image is histogram equalised. Note that this operation operates
on the entire 8-bit displayed image and so is inferior to using the
histogram equalisation under enhancements (which operates in
16-bits). However, it is quite useful for histogram equalising
cropped or magnified images.

Increase Contrast
Increases contrast in the image. Use multiple times to increase con-
trast more.

Flip Image Rotates the image 180 degrees.

White Background...
Sets the background on an image which has been geometrically
transformed (i.e. the Projection was set to something other than Nor-
mal), from black to white. This option does not work on JPEG
images viewed using View Image. See also White background on pro-
jections in Image Settings under Record in the File menu for setting the
background to white for automatically saved images.

Shift Image...
After selection, a point on the displayed image may be selected
which will be set as the new left edge.

Crop Image...
After selection, by clicking and dragging a box, the region to be
cropped may be selected. Then clicking inside the box will crop the
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image; clicking outside the box will cancel the operation.

Rotate Image...
Allows the image to be rotated. After selection, drag a line from left
to right. This line will become horizontal in the rotated image.

Resize Image...
A sub-menu allows selection of the new size (as a percent of the
original). The image can only be reduced in size. The image can be
reduced several times to create very small images.

Magnify Area...
A sub-menu allows selection of the degree of magnification (as a
percent of the original). After selection, by clicking and dragging a
box, the region to be magnified may be selected. Then clicking
inside the box will cause that part of the image to be magnified;
clicking outside the box will cancel the operation. Magnification
uses interpolation to minimise pixelation.

View Enhancement Curve
Shows the current enhancement curve or palette for the selected
enhancement in the Enhancements menu. If the enhancement is a
histogram equalisation enhancement, then the histogram equalisa-
tion for the current image will be shown.

Undo All (Decode)
Does a decode, which has the effect of undoing all shift and crop
operations.

Filename Template
The filename template specifies the output filename format. This can be found
in File Names and Locations... under the Options menu. If the filename tem-
plate is left blank it defaults to the original pathname. The % sequences in the
filename template are replaced as defined below. All replacements will be con-
verted to lowercase.

For example an Filename Template of:
%s-%T-%e

Could produce output filenames like:
meteor3-01061123-norm.jpg
noaa-12-01062348-msa.bmp
noaa-01062352-mcir-precip.png
noaa-01062350-raw.png
met7-01022603-norm.png

Templates may expand to create directories, for example:
%Y/%m/%d/%s-%e
%Y\%m\%d\%s-%e

under Linux/*NIX/MacOS X and Windows/DOS respectively.
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%@ causes any time or date % sequences (either before or after the %@)
to use local time rather than UTC time.

%s is replaced with the satellite name in lower case (up to 8 characters,
e.g. met7, noaa-14, meteor3).

%N is replaced with the satellite name in mixed case and with spaces
(e.g. MET7, NOAA 17, Meteor 3-5).

%g is replaced with the satellite type in lowercase (e.g. met, noaa,
meteor3).

%D is replaced with the satellite direction, either northbound or south-
bound.

%p is replaced with a single character abbreviation for the satellite direc-
tion, either N for northbound or S for southbound southbound.

%E is replaced with the maximum elevation for the pass in degrees
(0-90).

%ˆ is replaced with the azimuth at maximum elevation for the pass in
degrees (0-360).

%z is replaced with a single letter, either E or W to specify the azimuth
is more easterly or more westerly at maximum elevation.

%: is replaced with either east or west to specify the azimuth is more
easterly or more westerly at maximum elevation.

%f is replaced with the original audio input filename but without any
folder or directory name nor with any extension (e.g. if the input
filename is /tmp/03042215.wav then %f is replaced with 03042215).

%F is replaced with the format (either apt or wefax).

%C is replaced with the WEFAX spectral band or NOAA APT channel a-
channel b. Up to 3 characters, e.g. WEFAX: vis, ir, nir; NOAA APT:
2-4, 3-4. If unknown will be replaced with nothing.

%e is replaced by the name of the enhancement (e.g. za, hvc) or raw for
raw, pris for pristine, norm for normal (no enhancement). With the
histeq and norm enhancements, if only the A or B channel is selected
then the name of the enhancement is appended with a or b (e.g. his-
teqb, contrasta, norma).

%l is replaced by the sector. Up to 4 character sector information from
WEFAX digital headers. If not available (or APT), will be substi-
tuted with nothing.

%8,9,10,11%
is replaced by the 9th, 10th, 11th and 12th characters from the
WEFAX digital header (they appear off by one because numbering
starts at 0). The valid range of the numbers is 0 - 49 which
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corresponds to the 50 characters in the digital header. The numbers
start at 0, are separated by commas, and a % ends the sequence. If
the character selected is a space (or is otherwise not available) then
nothing will be substituted (i.e. the resulting filename will not con-
tain space characters).

%r is replaced by the satellite radio frequency in MHz (e.g. 137.50).

%k is replaced by the date in YYMMDD format. For WEFAX this is the
date embedded in the digital header from the image. For APT the
current UTC date is used. (Equivalent to %y%m%d).

%K is the same as %k but in DDMMYY format (equivalent to
%d%m%y).

%L is the same as %k but in MMDDYY format (equivalent to
%m%d%y).

%d is replaced by the 2 digit day of the month (01-31).

%m is replaced by the 2 digit month (01-12).

%y is replaced by the year without the century (e.g. 01).

%Y is replaced by the year with the century (e.g. 2001).

%T is replaced by the date and time in MMDDHHMM format. For
WEFAX this is the date and time embedded in the digital header
from the image. For APT the current UTC time is used. (Equivalent
to %m%d%H%M).

%t is replaced by the time in HHMM format. For WEFAX this is the
time embedded in the digital header from the image. For APT the
current UTC time is used. (Equivalent to %H%M).

%H is replaced by the 2 digit hour (24-hour clock) (00-23).

%I is replaced by the 2 digit hour (12-hour clock) (0-12).

%= on MTSAT or GMS images is replaced by the 2 digit hour (24-hour
UTC) given in the digital header. For other satellites, this will be the
same as %H.

%P is replaced by the AM/PM designation.

%M is replaced by the 2 digit minute (00-59).

%Z is replaced by the timezone name or abbreviation.

%% is replaced by %.

Image Output Formats
Images may be produced in JPEG, PNG, BMP, PBM (PGM/PPM/PNM), or AVI
format.

The output format: JPEG (.jpg), PNG (.png), BMP (.bmp), PNM (.pnm), or AVI
(.avi) used for output is specified by the filename extension. If you do not use
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an extension, or the extension does not relate to one of the supported output
formats, the default will be the format set in the Image and Movie Options...
under the Options menu.

JPEG files are a lossy compressed format. The quality (Image and Movie Options
under the Options menu) can be varied to control the amount of detail pre-
served and the amount of compression. Quality can vary from 0 to 100. The
useful range is probably 30 to 95 where a quality of 30 produces a well com-
pressed image (although lacking in much detail and with some significant arti-
facts), whereas a quality of 95 produces a very good image, but with little com-
pression. JPEG cannot support 16 bit grayscale images. JPEG images can con-
tain comments.

PNG files are a compressed lossless image format. Due to having good com-
pression and being lossless they are the preferred format. PNG supports 16 bit
grayscale images, comments, and records gamma.

BMP files are an image format widely used on PC based systems. The BMP
files produced by WXtoImg are not compressed. BMP files cannot support 16
bit grayscale images, nor can they contain comments.

PBM files are an uncompressed image format but well suited to further process-
ing and display on *NIX systems. PBM (bitmap) files are also called PPM
(colour), PGM (grayscale), and PNM (any). They support 16 bit grayscale
images and comments.

AVI files are animated sequences of images. AVI files support different types of
compression, RGB which is uncompressed, JPEG which uses JPEG compres-
sion, and MJPG (or Motion JPEG) which uses a special abbreviated form of
JPEG compression. The type of compression used in the AVI file is controlled
with the configuration file parameter AVI Codec. For JPEG and MJPG the AVI
quality (Image and Movie Options under the Options menu) will control the qual-
ity of the AVI animation. AVI files use a lower default quality to achieve better
compression. Because of the motion, lower image quality is needed. When you
select an AVI file for output, if the file exists, the new image will be added to the
end of the sequence. If the AVI file does not already exist then a new AVI file
will be created with only the new image. If the AVI file already contains the
maximum number or greater of frames (images) in the sequence then the first
frame (or frames) will be removed so that the total number of frames will be the
maximum after the new image is added.

Volume Control
When recording signals it is important that the volume is not set too high or too
low. If the volume is set too high, clipping will occur and detail will be lost in
the white areas of the image. If the volume is set too low, some detail will be
lost throughout the image.

The volume should be adjusted so that the vol which is displayed when the sig-
nal is processed is between about 50.0 and 75.0. Higher numeric values of vol
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(e.g. 92.3) indicate that the volume should be decreased, lower numeric values
of vol (e.g. 24.7) indicate that the receiver volume should be increased.

The volume will be displayed when a signal is being recorded. The volume on
the receiver can be easily adjusted during a satellite pass to set a reasonable vol.
Note that it is not recommended that the volume be changed during every
satellite pass (as the resulting images will show bands of light and dark). The
volume should be set once and then left alone.

If using 8-bit audio files, the volume should be slowly increased until the vol
shows between about 85.0 and 92.0. Unfortunately, each satellite will require a
different optimal volume setting. Results will never be as good as images cre-
ated from 16-bit recordings, especially where any of the image enhancements
are used.

If the volume is set very high, WXtoImg may issue a warning message.

Equipment Required
In order to make use of this program for APT transmissions you will need a
receiver capable of receiving FM signals in the 137-138MHz band (look for
satellites at 137.30, 137.40, 137.50, 137.62, 137.80, and 137.85 MHz). A purpose
designed weather satellite receiver is the best option as the sensitivity and IF
bandwidth (about 50kHz) will be correct.

Scanners and general purpose communications receivers can be used, however
these often have a very narrow IF bandwidth (close to 15kHz) with the result
that whites (above about 128 on a scale of 0-255) invariably will be noisy and
clipped. The narrow bandwidth will also cause a lot of noise except when the
satellite is straight overhead as the doppler-shift combined with the narrow IF
bandwidth will result in a very poor signal. However, the upgraded versions of
WXtoImg adjust the frequency to compensate for doppler shift on supported
receivers with an RS-232 connection. Some communications receivers have a
30kHz (acceptable if the frequency is adjusted using an upgraded version of
WXtoImg) or 50kHz IF filter option, and there are modifications for a few scan-
ners to increase the IF bandwidth. A pre-amp can help with the poor sensitiv-
ity, but these modifications may not result in the same image quality as a pur-
pose designed weather satellite receiver.

The upgraded versions of WXtoImg also contain special code to much more
accurately build colour enhancements when using narrow bandwidth receivers.
The upgrade will be of considerable benefit to those getting reasonable images
when using the Contrast enhance (NOAA ch B only) enhancement.

A special antenna will be needed regardless of which receiver you have avail-
able. You can build an antenna and there are several designs for the highly rec-
ommended QFH antenna available on the Internet. Turnstile and crossed
dipole antennas are other options.

You will, of course, need an audio cable between the "speaker out" of your
receiver and the "line in" on your sound card.
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Finally, it may help to know when the polar orbiting weather satellites are pass-
ing overhead, so you might want to obtain a tracking program. However, in
record mode WXtoImg will let you know the next satellite pass is expected.

For WEFAX transmissions from geostationary satellites, the most common
method is to use a small parabolic dish antenna, coupled with an active feed
and down converter to convert the 1600 MHz band signal to the 137 MHz band.
Then the same receiver can be used for these satellites. See references for more
information.

References and more Information
Paul Hayes has information on building a QFH antenna at:

http://homepage.ntlworld.com/phqfh1/qfh_diy_guide.htm

Also check out the information and FAQ on the WXtoImg home page at
http://www.wxtoimg.com/

Terms and Conditions
The WXtoImg programs (which include wxtoimg, xwxtoimg, wxrec, wxmap,
wxproj, and wxbatch) and documentation are not warranted to be free of bugs.
You should backup your system before installing this software. Because of the
nature of the analog signals and complex processing performed do not expect
results of this program to be correct in any or every instance.

The WXtoImg programs and documentation are supplied "AS IS". Central
North Publishing Limited disclaim all warranties, expressed or implied, includ-
ing, without limitation, the warranties of merchantability and of fitness for any
purpose. Central North Publishing Limited assume no liability for direct, indi-
rect, incidental, special, exemplary, or consequential damages, which may result
from the use of the WXtoImg programs, even if advised of the possibility of
such damage.

The WXtoImg programs and documentation are not intended to be used where
life, health, safety, or property may be at risk.

The freeware edition of the WXtoImg software may be used for personal, non-
commercial purposes free of charge. Additional features are available only to
those who upgrade their copies of the software.

Use by any commercial organisation, or any individual for commercial pur-
poses requires the purchase of a professional edition upgrade key. An upgrade
key may be obtained from:

Central North Publishing Limited
P.O. Box 99597
Newmarket
Auckland
New Zealand
Email: http://www.wxtoimg.com/email.html
http://www.wxtoimg.com/reg/
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The WXtoImg programs and documentation may only be redistributed for per-
sonal use, on a non-commercial basis, and in their original, unmodified pack-
ages. No other redistribution is permitted. Central North Publishing Limited
reserves the right to stop redistribution. Upgrade keys may be installed on a
single computer and may not be produced, distributed or disclosed to other
parties. You may install the upgrade key on a laptop in addition to the primary
computer as long as you only run WXtoImg on one computer at a time. You
may not disassemble, reverse engineer, decode or decrypt this software or make
use of information, code or algorithms obtained in this way.

The WXtoImg programs are Copyright (c) 2001-2010 Central North Publishing
Limited. All rights reserved.

Credits
Special thanks to Andreas Rehberg, Gerd Berg (DK1RR), John Boudreau,
Adrian Chamberlain, Ari Ervaskivi, Andy Eskelson, Jakub Gorzynski (SQ2WB),
Les Hamilton, Paul Hayes, Paul Holder, Nakato Mikiya, Pauli Nunez
(EA3BLQ), Andre Phillips, Steven Ross, Jeremy Royle, Hartmut Schaksmeier
and many others who beta tested the numerous early versions of this software.

NOAA provided a wealth of information on their web-site and in their publica-
tions, developed most of the enhancement curves used in WXtoImg, and pro-
vided outstanding support.

Notices
Copyright (c) 2001-2010 Central North Publishing Limited. All rights reserved.

The ZA, MB, MD, BD, CC, EC, HE, HF, JF, JJ, LC, TA, WV, and NO enhance-
ment curves were provided by the National Oceanic & Atmospheric Adminis-
tration (NOAA).

JPEG support, in part, provided by the Independent JPEG Group.

Text overlay support based on the work of the FreeType Team.
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Calibration
WXtoImgmust be setup and calibrated to achieve useful results. Setup requires setting
the location of your receiver and downloading the latest Keplers. Calibrationmust be
performed in two areas: the first is the volume of the recording, the second is to match
the sampling frequency to the sound card sample rate.You need to perform this calibra-
tion only once.

Before you Begin
Simply connect your receiver’s audio output to theline input of your soundcard using a
suitable cable. If you have an ICOM PCR1000 receiver, ensure that you follow the
instructions in the manual for setting the internal jumper for line level output (or alterna-
tively use the PCR100 setting instead).

The polar orbiting satellites transmit on 137.10, 137.40, 137.50, 137.62, or 137.9125
FM (50kHz or NFM) and each satellite will pass by twice per day (about 12 hours
apart) at roughly the same times each day. You may be able to catch lower elevation
passes about 1.5 hours before and after the best pass. Note that all satellites will not be
transmitting depending on on time of year, the time of day, their proximity to other
satellites, and whether they are working or not.A good pass lasts approximately 10 to
15 minutes.When WXtoImg is in record mode it will indicate the next satellite pass
and the frequency on which it is transmitting.

Setting the Ground Station Location
SelectGround Station Locationfrom theOptionsmenu. Enterthe name of your city
and country. If the city you live in has a population over about 100,000 then click on
theLookup Lat/Lonbutton. If you are at sea, you can enter any description you like for
city and country.

If you could not lookup the latitude and longitude, then you’ll have to enter the latitude
and longitude of your location.Latitude and longitude must be entered in degrees and
fractions of degrees (e.g. 52.500, not 52:30, nor 52:30:00, nor 52:30.00). North and east
should be entered as positive numbers, south and west should be entered as negative
numbers. Ifyou do not know the latitude and longitude of your location, then try the
closest large city (population >100,000) and click onLookup Lat/Lon. If you do not
know the altitude just enter 0.0.

Updating the Keplers
Current U.S. government regulations mean you should obtain an account from Space
Track to gain access to the Keplerian elements required for WXtoImg.However, at
present you can use Celestrak without an account (see Options -> Internet Options).
Accounts are generally simple and fast to obtain from:

http://www.space-track.org/
Once you obtain an account, you will need to login to this account and change your
password. ThenopenInternet Optionsfrom theOptionsmenu, and type in your Space
Track username and new password.

Now, connect to the Internet and selectUpdate Keplersfrom theFile menu to download
the latest orbiting elements for the weather satellites.If you do not have an Internet
connection, then ignore this and instead selectDisable Map Overlayfrom theOptions
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menu.

Checking for Satellite Passes at Your Location
SelectSatellite Pass Listfrom theFile menu. Thiswill display a list of satellite passes
from the current time to 7 days ahead for your location.Times are given in both local
time and UTC.

Adjusting the Volume
Set the volume control on your receiver to a low to moderate level, then selectMixer
Control... from theFile menu. Configurethe mixer to take input from the source the
receiver is plugged into (normally the Line In), set the PCM and Recording (cassette)
levels (Linux only) all the way to the top. Set the Line level (Linux and Windows) at
about the mid-point. Set the igain (Linux only) to it’s mid-point. It is better for the vol-
ume and line levels to be too low than too high to start with.

Under Windows 95 you may have to selectPropertiesfrom theOptionsmenu on the
Mixer control and check theRecordingbutton, and check theLine volume control
before you can adjust the controls as above.

SelectRecord...from theFile menu, and click onAuto Record.

Wait for a satellite to arrive. WXtoImg will indicate when the satellite is expected (in
UTC) and on what frequency the satellite is transmitting in the status bar.

WXtoImg will record the pass -- during the pass an image may be shown, do not be
concerned with the brightness or darkness of the image or other problems such as it
consisting only of diagonal lines. When setting the volume never use this image as a
guide -- use only the volume setting discussed below. After recording is complete
WXtoImg will build a map and re-decode the image. It does this to produce the best
possible results.

Av oid using the scrollbars to scroll the image while recording -- this can cause the
resulting image to be split.

The program volume (vol) will be displayed when the signal is being recorded. If a
satellite is passing overhead and the status line indicates that the program is still waiting
for carrier or waiting for signal then the receiver volume may be too low or the mixer
input level may be set too low. Slowly increase either or both until the status line indi-
cates the signal is being recorded.The volume on the receiver (or the recording level on
the mixer) can then be easily adjusted during the pass to set a vol between 50.0 and
75.0. If the receiver has no volume control or the volume control does not affect the
speaker output, then adjust the mixer settings (recording, igain, or input line level) until
the displayed vol is between about 50.0 and 75.0.The volume bar should be green
when a signal is being received, red or yellow indicates the volume is too high or too
low.

The image will be re-decoded after the satellite has passed.When the decode is com-
plete, the overall volume will be shown on the right hand side of the status line below
the image.

The overall volume should be between about 40.0 and 85.0.Higher numeric values of
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vol (e.g. 90.2) indicate that the volume should be decreased, lower numeric values of
vol (e.g. 24.7) indicate that the volume should be increased.

If the volume is set too high, clipping will occur and detail will be lost in the white areas
of the image. If the volume is set too low, some detail will be lost throughout the
image.

Except for this calibration, avoid adjusting the volume when the satellite is passing
overhead. Adjustingthe volume during a pass will produce banding in the final image
and will adversely affect temperature calibration.

Adjust the volume appropriately and repeat.

Adjusting the Sampling Frequency (Slant Correction)
Start by selectingDisable PLLfrom theOptionsmenu. Disablingthe PLL allows us to
properly set the sampling rate.

Next, select a recording to decode.SelectOpen Audio File... from theFile menu, and
choose a recording. Ideally you’d like a  recording from a satellite on a high overhead
pass.

Now, wait for the image to be decoded and displayed. The image will be bent slightly
from top to bottom as a result of the doppler shift.This is normal when the PLL is dis-
abled.

SelectSlant Correction...from theImagemenu. Scrollto the top of the image and click
on a vertical edge in the image. Continue holding the button down and drag a line to the
bottom of the image.Allow the image to scroll until you get to the bottom of the image.
Ensure the pointer is over the same edge that you originally clicked on and release the
button.

A dialog box will pop up and display the suggested sampling rate.The WXtoImg pro-
gram can estimate the sampling rates for all other satellites.You should select theEsti-
mate and set sampling frequencies for all satellitesoption if it is not already selected,
then click onSet.

Un-selectDisable PLL from the Options menu. Theimage will be re-decoded and
should be completely straight. If it is bent or jagged, ensure that you have un-selected
Disable PLLin theOptionsmenu. Ifit is slanted, then try repeating the process, paying
close attention to these instructions.

While options are (by default) saved on exit, you should ensure the sampling frequen-
cies are saved by selectingSave Optionsfrom theOptionsmenu.

Copyright
Copyright (c) 2001-2010 Central North Publishing Limited. All rights reserved.
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Recording
Why do I get a message Warning: couldn’t find telemetry data when WXtoImg dis-
plays an image?
You need to adjust the sampling frequency. Information on adjusting the sampling fre-
quency can be found in theRequired Calibration... document under theHelp menu.
Also see theSlant Correctionsection in this manual.

Why do I get Error: waveInOpen failed! when WXtoImg tries to record?
OpenRecord Options in theOptionsmenu, and change the soundcard (even if your PC
only has one soundcard you may need to change this for recording to work). Click OK
and enter record mode again to test.Try all soundcard values until you find one that
works. If this fails to eliminate the problem you may need to install or re-install the lat-
est drivers for your soundcard.

Why does recording never start?
Ensure that the audio cable from the receiver is attached to the soundcard Line 1 input.
Ensure that you have used the speaker (and not line) output from the receiver. Follow
the instructions carefully in theRequired Calibration...section under theHelpmenu.

Why is the image split (sometimes referred to as sync loss)?
The image looks as though it has been cut horizontally and the upper or lower portion
shifted left or right.This may occur in just one place or in multiple places in the image.

UnderOptions, enableResyncwhich will correct most of these problems.

However it is best to minimise the occurrance of these splits in the first place.The
problem is caused by other programs doing a lot of activity or using a lot of CPU or
memory or performing a lot of disk i/o while WXtoImg is recording.Limiting the num-
ber and activity of other programs while WXtoImg is recording should eliminate the
problem. Somescreen savers can also cause this problem, so setting your screen saver
to none would be a good idea.

Why does the program hang with a Status: opening soundcard... message?
The soundcard is in use by another program (possibly even the mixer). Closeother pro-
grams (including the mixer if it is running).

Why does recording start immediately and never stop recording when I try to
record signals from polar orbiting satellites?
Most likely your receiver does not have squelch on the audio out. Select either the
Record when 2400 Hz carrier presentor Record only when selected active APT satel-
lites are overheadmode.

Why does it never stop recording when I try to record signals from geostationary
satellites?
You need to select theRecord using WEFAX start/stop tonesmode in theRecording
Options...dialog under theOptionsmenu.

Why do I only record every other image from geostationary satellites?
Processing is taking too long.You can reduce processing time by disabling Options ->
Despeckle (or setting it tonone). Despeckleis generally inappropriate on WEFAX
images because it degrades the fine lines in the maps. Setting Options -> Sharpen to
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nonewill marginally improve processing speed.

You can further reduce processing by settingMaximum number of thumbnailsto 0 in
GUI Optionsin theOptionsmenu.

Also ensure that you have not selectedUse for audio recordings/maps tooin File Names
and Locationsunder theOptionsmenu. Renamingthese files requires significant extra
time. Finally reduce the number of autoprocessing images and steps performed under
Recordin theFile menu.

If your computer still isn’t fast enough to complete processing before the next image
arrives consider upgrading your computer. Alternatively you can selectRecord only
(show image if enabled) from Recordunder the File menu. In this mode, only audio
files can be saved, but the program will show the image as it is being recorded.

The program tries to record polar satellites at the wrong time, what needs to be
done?
Check your time and timezone setting are correct. On Windows open the Date/Time
control panel (Start -> Settings -> Control Panel -> Date/Time), ensure that the "Time
zone" is for a nearby city, that "Automatically adjust clock for daylight savings
changes" is selected, and that the time is correct.

On Windows, check yourautoexec.batfile for a setting starting withSET TZ=. This
will override the timezone settings set in the Windows control panel and can cause prob-
lems for WXtoImg. Remove the line or comment it out.

How can I automatically remove the older images and recordings?
SelectRecordfrom theFile menu. Thereare separate options for when to remove audio
files, raw images, maps, and images. Choose a time for these to be deleted.Select
Accept, then selectSave Optionsfrom the Options menu. Notethat files are only
deleted if they hav ebeen created automatically by WXtoImg.If you useSave Image as
or Save Raw Image as the files created will not be automatically deleted. Audio files
created by other programs will also not be deleted.

Image Slant
Why do I get a message Warning: couldn’t find telemetry data ?
You need to adjust the sampling frequency. Information on adjusting the sampling fre-
quency can be found in theRequired Calibration... document under theHelp menu.
Also see below.

Why are my images slanted?
You need to adjust the sampling frequency. Information on adjusting the sampling fre-
quency can be found in theRequired Calibration... document under theHelp menu.
Also see below.

I can’t find a vertical edge in the image to use for slant correction.
Ensure you have selectedDisable PLLfrom theOptionsmenu, and then selectedSlant
Correctionfrom theImagemenu.

This is because your soundcard is sampling very far from the 11025 Hz that it should
be. This isn’t a problem. Your image will have sloping horizontal lines running
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through it. Instead of dragging a line along a vertical edge, just drag a line along one of
the sloping (near horizontal) lines from left to right across the image.

Next selectEstimate and set sampling frequencies for all satellitesand click onSet.

ChooseDecodefrom the File menu and repeat the procedure.This time the edges
should be near vertical.

Remember to ensureDisable PLLis not selected and then chooseSave Optionsfrom
theOptions Menuto save the slant correction settings.

Map Overlays
Can WXtoImg produce map overlays from recordings made by other programs?
Yes. However it may be necessary to changeAudio file namingto Other, in the File
Names and Locationsdialog under theOptionsmenu. Thisoften needs to be done even
if the filenames are MMDDHHMM.wav (month, day, hour, minute) because WXtoImg
requires that this date be the time of the start of the recording and not the time when the
satellite came over the horizon.

Why do I not see map overlays and often get a message that WXtoImg could not
find matching pass to build overlay map ?
Ensure that you have set the latitude and longitude underGround Station Location...in
theOptionsmenu to match your location.

Also check that the appropriate satellite type is selected in theActive APT Satellitessub-
menu in theOptionsmenu.

It could also be that your computer’s clock is off significantly (5 minutes or more).See
Why are the maps never aligned correctlybelow.

Finally, your timezone setting may be incorrect so that the calculation of UTC time will
not be correct. On Windows open the Date/Time control panel (Start -> Settings ->
Control Panel -> Date/Time), ensure that the "Time zone" is for a nearby city, that
"Automatically adjust clock for daylight savings changes" is selected, and that the time
is correct.

Note that the Ground Station Location, needed for generating maps, is not used in deter-
mining UTC time.

Why are the maps never aligned correctly?
The most common cause is that the computer’s clock is off by more than a 250ms (a
quarter of a second).In order for overlays to be aligned accurately the computer’s clock
must be very accurately set. On Windows XP and Windows Server 2003, WXtoImg can
set the clock to an Internet time source.SeeInternet Optionsin the Optionsmenu.
Upgraded versions of WXtoImg can synchronise the PC’s clock to a GPS. If you are
recording on a different computer, then the clock on the recording computer must be set
correctly.

My clock is accurately set, what other causes are there?
Using out-of-date Keplers will also cause the maps to be incorrectly aligned. Just use
theUpdate Keplersoption under theFile menu.
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Also if you use recordings that were copied from some other place, then the timestamp
on the recording may be affected resulting in maps which are significantly mis-aligned.
Look for a copy program that preserves time-stamps (under *NIX use cp with the -p
option, or use mv instead).

What can I do about overlays that are still missing or not correctly aligned?
Use theMove Overlay... option under theImagemenu to move incorrectly aligned over-
lays.

On Windows, check yourautoexec.batfile for a setting starting withSET TZ=. This
will override the timezone settings set in the Windows control panel and can cause prob-
lems for WXtoImg. Remove the line or comment it out.

Check that your Internet firewall is configured to allow connections from WXtoImg
(xwxtoimg.exe), so that the Keplers can be updated.

Keplers
How often should I update the Keplers?
In order to avoid having to move the map overlay, Keplers should be updated every few
days. Connectto the Internet, then selectUpdate Keplersfrom theFile menu.

I cannot update the Keplers, what’s wrong?
Check your Internet connection.If it is OK and Update Keplers fails it is likely because
your Internet firewall is not configured to allow xwxtoimg.exe to make connections to
the Internet (via HTTP port 80). Check your Internet firewall manual for details.

I do not have access to the Internet, how can I update the Keplers?
If you have email access and can get the Keplers emailed to you or sent on floppy disk
or other media, then simply copy a file of two line elements into \Documents and Set-
tings\...your name...0lication Data\WXtoImg\weather.txt under Windows, or
˜/.wxtoimg/weather.txt under *NIX.

General
Why do I get the warning message enhancement ignored: could not find a NOAA
sensor 2 (or 3) image ?
The operational NOAA satellites send images from two sensors. Atnight, images from
sensor 3 (mid/thermal infrared) and sensor 4 (thermal infrared) are sent. During day-
light (and dusk) sensor 2 (visible/near infrared) and sensor 4 (thermal infrared) are sent.
The warning indicates that the enhancement you have chosen (from the Enhancements
menu) requires a sensor which is not available in the current image. In this case
WXtoImg ignores the enhancement chosen and produces a "Normal" enhancement
image instead.

I’m using WXtoImg under Linux, and the font sizes are very large (or very small)
in some places.
This is because the monitor size is not set correctly in your X-Windows configuration.
You will need to add a line (or correct the existing one) that describes your monitor
width and height in mm. Edit the X-Windows configuration file (often
/etc/X11/xorg.conf) and in the "Monitor Section" add:

DisplaySize 330 210
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replacing 330 and 210 with the width and height of your monitor’s screen in millime-
ters. Thenlogout and log back in.

Why do i get a Runtime Error! ?
If WXtoImg crashes with a message from the "Microsoft Visual C++ Runtime Library",
stating that there was a "Runtime Error!" and that "This application has requested the
Runtime to terminate it in an unusual way. Please contact the application’s support
team for more information", then you have a video driver problem.

Obtain and install the latest drivers for your graphics card/chipset. In most cases this
will solve the problem.However, the issue surrounds displaying large images or many
thumbnails in WXtoImg, so you can work around the problem, by decreasing theMaxi-
mum number of thumbnailsin GUI Optionsto 100 or less (sometimes 50 or less).And
if you are performing image projection changes, by reducing theProjection scale.

How can I get images that show exactly the data that was received from the satel-
lite?
SetEnhancementto Pristineand enableShow Allin theOptionsmenu.

Can I process old .WAV fi les from satellites that haven’t transmitted for a long
time?
Yes. Firstenable expert mode inGUI Optionsunder theOptionsmenu. ExitWXtoImg
and start it again. Now select the satellite you wish to process the WAVE file for from
theSatellitemenu. Openthe WAVE file usingOpen Audio Filein theFile menu.

If the program fails to build a map, it is likely because the date/time stamp on the
WAVE file is not correct.You’ll need to ensure the file is named YYYYMMDDHH-
MMSS.wav for the UTC time it was recorded (i.e. 19990928025912) for 28 September
1999 02:59:12 UTC. Be as accurate as possible with the time, but generally +/- 5 min-
utes will be OK (however you will have to move the map usingMove Map Overlay
from the Image menu). Now openFile Names and Locationsfrom theOptionsmenu
and setAudio file naming to YYYYMMDDHHMMSS UTC time. Click OK. Finally open
your renamed file using Open Audio File.

Why are some menu items gray and not selectable?
These items are available only in the upgraded version. Informationon upgrading is
available at:

http://www.wxtoimg.com/reg/

Note that while in record mode or when images are being processed all of the options
exceptHelp, Stop, andExit are gray.

How do I display local time instead of UTC time?
This applies only to copies of WXtoImg with an upgrade key installed. Disablethe
Show time as UTCsetting inGUI Optionsin theOptionsmenu.

To change time on the text overlays (only), OpenTe xt Options from the Options menu.
Replace UTC with %@%Z or %@local or use %@ followed by your time zone (e.g.
%@EST). SelectOK.

Hints for impr oving image quality.
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If you are using a narrow bandwidth scanner or communications receiver, then purchase
an upgrade key, openRecording Options, and setreceiver typeto Scanneror Communi-
cations. By doing this, the software will use special processing modes to dramatically
improve image quality with colour enhancements. If you have a computer control cable
for your receiver and the receiver is shown in the list, then select the specific receiver
instead. Even better images will be obtained when WXtoImg can control the receiver.
Purchase the upgrade only when you have clearly recognisable images using theCon-
trast enhance (NOAA ch B only) option.

For APT images setDespeckleto 2.0 in theOptionsmenu to help eliminate some of the
random noise.For WEFAX imagesDespeckleshould usually be set tonone.

On upgraded versions, setMinimum Solar Elevation for visible images to 15.0 in the
Recorddialogue in theFile menu.

Set Illumination Compensationto Full or Med or any other choice thanNonewhen
Contrastis set toLinear (constant).

If you are producing an image for printing, setGammato none in the Optionsmenu,
and save the file as a PNG file (by placing.pngon the end of the filename).

If you are creating movies/animations, etcAVI Codec to RGB in Image and Movie
Optionsin theOptionsmenu. Thiswill create much larger animations, but will greatly
improve the quality. Note that you’ll have to delete your existing animations before the
change takes effect (the codec is only set when the animation is created for the first
time).

When using one of the Anaglyph enhancements from NOAA satellite passes at dusk or
night, enableUse other sensorin theOptionsmenu. Alsosave your anaglyph images as
PNG or BMP files (just use a.png or a .bmp extension. Thisis usually necessary
because the lossy JPEG format can cause colour shifts that adversely affect the 3-D
effect.

To remove the noisy portions of the image at the top and bottom, open theRecording
Options...dialog in theOptionsmenu and selectRecord only when selected active APT
satellites are overhead, then setrecord only when satellite is above (degrees)to about
15. Thiswill ensure that recording only takes place while the satellite is at least 15
degrees above the horizon. Note that the best value will depend on your environment
and receiving equipment (values between 8 and 18 would be typical).

How can I create images that I can import into Digital Atmosphere?
This applies to upgraded versions only. EnableDA compatible BMP formatin Image
and Movie Optionsin theOptionsmenu. SetProjectionto Orthographic. OpenProjec-
tion Optionsfrom theOptionsmenu. SetScaleto 640 (or if you’ve changed the map
width use the width of your DA map is in pixels). Lookat the DA map and guess as
closely as possible the most northern and southern latitudes and the most eastern and
western longitudes (in degrees and decimal degrees). Usethese values (negative for
south and west, positive for north and east) for the North, South, West, and East bound-
aries. SettheReference Longitudeto the longitude at the centre of the DA map. Setthe
Reference Latitudeto the latitude at the centre of the DA map.
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How do I print an image?
Because WXtoImg has no built in print facilities, you must first save the image to a file
(selectSave Image As under theFile menu). Endthe filename with .png or .bmp to cre-
ate a PNG or BMP image rather than the default JPEG (this will improve print quality).
You may also want to setGammato nonein theOptionsmenu before saving the image.
Once the image has been saved you can open it with a variety of programs, including
photo editors or your Internet browser and print it.

Why do the colours on my screen go strange when I run WXtoImg?
This is because you have a graphics adapter set to 256 Color (8-bit) mode.WXtoImg
grabs all 256 colours for it’s own use -- which allows it to display much better images.
You could try changing the display settings to True Color (24 or 32 bit) or High Color
(15 or 16 bit). If your display adapter is not capable of more than 256 colours and you
really dislike this feature, it can be disabled by un-selectingUse private colormap,
underGUI Options in the Optionsmenu. Rememberto Save Options, then exit and
restart the program.

What does northbound 51 W mean?
This is a description of the satellite pass.Southbound or northbound indicates the direc-
tion the satellite is traveling. Themaximum elevation (in this case 51 degrees) is given
next. Notethat the maximum elevation will be between 0 and 90 degrees (with 90 indi-
cating a direct overhead pass). This is followed by an either E (east) or W (west) to
indicate if the satellite is traveling to the east or west of you (at the time of the maxi-
mum elevation).

I j ust want a nice false coloured image. How do I do that?
During the summer when images are well illuminated by the sun, the MSA Multispec-
tral analysis, HVC, and HVCT enhancements on NOAA satellites give good results.
Select these under theEnhancementsmenu.

During the winter or summer, day or night, the MCIR and NO enhancements on NOAA
satellites gives good results.

What does WXtoImg mean?
WXtoImg is shorthand for "WX to image" (weather satellite to image).

AVI A nimations
Can I build movies from polar orbiting satellites?
Yes, if you have purchased the upgrade. Here’s how to do it:

Open theImage and Movie Options...dialog under theOptionsIf you would like high
quality movies or wish to view 3-D movies using one of the Anaglyph enhancements
you might want to change theAVI Codecto RGB. (This will result in movies which are
very large, but will provide a better 3-D effect.) Otherwiseuse theMJPGcodec. Select
OK.

Open theRecorddialog from theFile menu. Ensurethat Record and auto processis
selected. EnsureCreate Movie(s)is selected. Then click on theMovie Settingsbutton.

Select the enhancements you would like for the movie. A movie will be made for each
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selected enhancement. The best enhancements for AVI movies would beMCIR map
colour IR (NOAA), Contrast enhance (NOAA ch B only), Sea Surface Temp, Anaglyph
false 3-D, Colour anaglyph false 3-D, NO colour IR enhancement, and ZA general IR
enhancement. You may also get reasonable results with theHVC false-colourand
HVCT false-colourenhancements.

Click on theEasy Set Defaultsbutton.

SelectSet.

Set theMinimum percent of projection filledto 50.0 so that frames with less than 50%
of the pixels filled will not be added.

Now click on theRecordbutton. Each time a satellite passes a frame will be added to
movie(s). You can view the movies that have been produced by selectingView Movie
from theFile menu.

Can I build movies from a bunch of old images, raw images or recordings?
Yes, if you have purchased the upgrade and if using processed or raw images, the
images were produced by WXtoImg.

SelectLinear (constant)from theContrastsub-menu in theOptionsmenu. Thishelps
to ensure that each frame in the animation will have similar brightness and contrast.

SelectFull from the Illumination Compensationsub-menu in theOptionsmenu. This
also helps to ensure that each frame in the animation will have similar brightness and
contrast.

Open theImage and Movie Options...dialog under theOptionsmenu. Changethe AVI
Scaleto 1.000. (If you wish to alter the size of the movie, use theProjection Scalein
the Projection Optionsdialog under theOptionsmenu instead.)If you wish to view
3-D movies using the Anaglyph enhancement you might want to change theAVI Codec
to RGB. (This will result in movies which are very large, but will provide a better 3-D
effect.) Otherwiseuse theMJPGcodec. SelectOK.

Open theProjection Optionsdialog from theOptionsmenu. You can change theCentre
Longitudeif desired to some longitude near you, or leave it blank. Now set the North,
South, West and East boundaries.Try setting them to about 10 degrees north, south,
west and east of your location.Latitude and longitude must be entered as a decimal
number in degrees and fractions of degrees. Usepositive numbers for north and east,
negative numbers for south and west.You must enter a value for all four bounds.
SelectSet.

Under theProjectionmenu, selectMercator(or any projection other thanNormal).

Under theEnhancementsmenu, select then enhancement you want to use for the movie.
The best enhancements for AVI movies would beMCIR map colour IR (NOAA), Con-
trast enhance (NOAA ch B only), Sea Surface Temp, Anaglyph false 3-D, NO colour IR
enhancement, and ZA general IR enhancement. You may also get good results with the
HVC false-colourandHVCT false-colour, andVe getationenhancements.

Now open a recording usingOpen Audio File, a raw image usingOpen Raw Image, or a
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processed image usingView Image from theFile menu. Whenprocessing is complete,
selectSave Image from theFile menu. Save the file to an AVI movie by setting the file-
name extension to.avi (e.g.noaa-za.avi).

Repeat the previous step for other recordings, raw images, and movies, saving them to
the same filename. When prompted to overwrite the file, selectyes. AVI movies are not
overwritten, instead a frame will be added to the end of the movie.

When you have added all the images, selectView Movie from theFile menu and select
the file you just created.

OK, but isn’t ther e an easier way to build many different AVIs from old images?
Yes. Follow the instructions forCan I build movies from polar orbiting satellites?but
in the last step, click on theAcceptbutton rather thanRecordbutton.

Now open a recording usingOpen Audio File, a  raw image usingOpen Raw Image, or a
processed image usingView Image from theFile menu. Onceprocessing is complete,
selectAuto Processfrom theFile menu. Repeat.

I cannot display the AVIs using Windows Media Player.
Unfortunately, older versions of the Windows Media Player do not support the MJPG
(Motion JPEG) encoding which is the default in WXtoImg version 1.0 and above. A
special codec is needed for Windows Media Player to play these files.You can get this
MJPG codec by installing Microsoft Direct X version 8.0 or above. Available from:

http://www.microsoft.com/directx

Note that Windows 95 users must download a different version of Direct X, and Win-
dows XP users do not need to install this.

If you still have trouble, check your display settings (Start -> Control Panel -> Display
-> Settings, or on XP: Start -> Control Panel -> Appearance and Themes -> Display ->
Settings) and set the colour quality to 32 bits or 24 bits.

Alternatively, the Apple Quicktime player for Windows works fine. It is available from:
http://www.apple.com/quicktime/download/

Finally, you could selectImage and Movie Options...from theOptionsmenu and set
AVI Codecto RGB. This will createvery large uncompressed animations, but this for-
mat is supported by almost every AVI viewer.

Note the Linux/*NIX xanim player supports the MJPG encoding method used.

Can I build movies of images from geostationary satellites?
Yes. Here’s how to do it:

First, open theRecording Optionsdialog from theOptionsmenu. SelectRecord using
WEFAX start/stop tones. SelectOK.

SelectLinear (constant)from theContrastsub-menu in theOptionsmenu. Thishelps
to ensure that each frame in the animation will have similar brightness and contrast.

Open theImage and Movie Options...dialog under theOptionsmenu. SettheAVI Scale
to 0.500. SelectOK.
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Open theRecorddialog from theFile menu. Ensurethat Record and auto processis
selected. EnsureCreate Movie(s)is selected. Then click on theMovie Settingsbutton.

Set theMovie Filename Templateto %s-%l-%C-%e.

Select the enhancements you would like for the movie. Onlysome of the enhancements
apply to geostationary satellites. If in doubt, just selectNormal. SelectOK.

Now click on theRecordbutton. Eachtime an image is decoded from the satellite it
will be added to the appropriate movie. A different movie will be created for each sec-
tor, each sensor and each enhancement.You can view the movies by selectingView
Moviefrom theFile menu.

Composite Images
Can I automatically build combined images from multiple satellite passes?
Yes, if you have purchased the upgrade. Here’s how to do it:

First, open theRecording Optionsdialog from theOptionsmenu. SelectRecord only
when selected active APT satellites are overhead. SelectOK.

If you wish to create composite images using the HVC, HVCT, or Anaglyph enhance-
ments you might want to select theUse other sensorin theOptionsmenu.

Open theRecorddialog from theFile menu. Ensurethat Record and auto processis
selected. EnsureCreate composite image(s) is selected. Then click on theComposite
Image Settingsbutton.

Select the enhancements you would like to create composite images for.

Click on theEasy Set Defaultsbutton.

SelectSet.

Note that theMinimum percent of projection filleddoes not apply to composite images.

Now click on theRecordbutton. Each time a satellite passes the images will be overlaid
on the composite images.You can view the composite images that have been produced
by selectingView Imagefrom theFile menu.

Can I build composite images manually?
Yes, if you have purchased the upgrade.

SelectLinear (constant)from theContrastsub-menu in theOptionsmenu. Thishelps
to ensure that part of the composite image will have similar brightness and contrast.

SelectFull from the Illumination Compensationsub-menu in theOptionsmenu. This
also helps to ensure that each part of the composite image will have similar brightness
and contrast.

Open theProjection Optionsdialog from theOptionsmenu. You can change theCentre
Longitudeif desired to some longitude near you, or leave it blank. Now set the North,
South, West and East boundaries.Try setting them to about 30 degrees north and south,
and about 30 - 40 degrees west and east of your location.Latitude and longitude must
be entered as a decimal number in degrees and fractions of degrees. Usepositive

version 2.10.10 10



WXTOIMG(FAQ) WXTOIMG(FAQ)

numbers for north and east, negative numbers for south and west.You must enter a
value for all four bounds. SelectSet.

Under theProjectionmenu, selectMercator(or any projection other thanNormal).

Under theEnhancementsmenu, select then enhancement you want to use for the com-
posite image.

Now open a recording usingOpen Audio File, a raw image usingOpen Raw Image, or a
processed image (from WXtoImg) usingView Image from the File menu. Opening
audio files or raw images will generally result in better results. When processing is
complete, selectComposite Image to from theFile menu. Betterresults can be achieved
by saving to PNG or BMP files (set the filename extension to.png or .bmp (e.g.
noaa-2401.png).

Repeat the previous step for other recordings, raw images, and movies, saving them to
the same filename. When prompted to overwrite the file, selectyes. Composite images
are not overwritten, instead the new image will be overlaid over the previous one.

Better results may be achieved by saving the lower elevation passes first and the highest
elevation pass last. This ensures that the best images occupy as much of the composite
image as possible.

When you have added all the images, selectView Image from theFile menu and select
the file you just created.

Creating Web Pages
Can I automatically create web pages and publish them?
Yes. Here’s how to do it:

Open theRecorddialog from theFile menu. Ensurethat Record and auto processis
selected. EnsureAdd images to web page is selected. Then click on theWeb Page Set-
tingsbutton.

If you have purchased an upgrade key, leave theHTML Templatealone for now.

Select the enhancements to use on the web page.When several enhancements are cho-
sen, the first available enhancement is used.Try "MSA,MCIR,contrast", then if the
MSA enhancement is available this will be used, otherwise the MCIR enhancement will
be used if available, otherwise just a contrast enhanced image will be used.

Choose a thumbnail size. Using 20.0% is recommended, although in some cases you
might find larger thumbnails (25.0%) look better.

TheHTML Filenameis the name of the HTML file that will be created.If unsure, leave
this asindex.html.

Most Internet Service Providers (ISPs) provide free home page access. Check with
your ISP about setting up a home page if you are unsure.Your ISP should provide you
with: the hostname for FTP access to your home page (Hostname), a username or login
for FTP access to your home page (User), and a password for FTP access to your home
page (Password). Enterthis information in the locations provided.
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For theDirectory you should enter the directory where your web page should be placed.
If the directory does not exist WXtoImg will attempt to create it.Your ISP may be able
to help you choose the directory name for use with FTP. Sometimes it needs to begin
with "/public_html/" or "/html/".

If you have an "always on" Internet connection, check the boxAutomatically FTP as
images are added, this tells WXtoImg to update your web page immediately and auto-
matically after each satellite pass is decoded.If you do not select this option you can
manually update your web page at any time by selectingUpdate Web Pagefrom theFile
menu.

Although this varies considerably from ISP to ISP, your web page may be accessed
using a URL similar to (replacingHostname, User, andDirectory):

http://www.Hostname/User/Directory/index.html
or

http://www.Hostname/˜User/Directory/index.html

Contact your ISP for more information about using FTP to load your own home page.

If you don’t want to publish the web page, you can create it in a folder or directory on
your computer:

Ensure the the boxPlace web page into folderis checked.

Enter the folder where you would like the web page built, you can click theBrowsebut-
ton to select an existing folder. The HTML Filenamewill be built in this folder (typi-
cally index.html).

After entering the FTP settings and/or the folder settings, selectOK.

You should be back at theRecorddialog. Ensurethat "Create Image(s)" is selected.
Now click on Image Settings. In the Enhancements section you should select the
enhancement(s) you chose forEnhancement to usein theWeb Page Settings.

Click OK.

Now click Accept.

Finally selectSave Optionsfrom theOptionsmenu.

SelectRecordfrom theFile menu. Each time a satellite passes the images and thumb-
nails will be created and a web page will be built.

How can I impr ove the quality of the images on my web page?
For theEnhancement to use(Web Page Settings, underRecordin theFile menu), select
an option that includes visible light imagery (e.g.MSA, MCIR, contrast).

Set theMinimum solar elevation for visible images setting (upgraded versions only
underRecordin theFile menu) to about15 degrees. Thiswill eliminate poorly lit visi-
ble images from being presented on the web page.

If you have selected a projection other thanNormal, set theMinimum percent of projec-
tion filled setting (upgraded versions only underRecordin the File menu) to about 66
percent. Thiswill prevent images with only a small fraction of the image filled from
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being presented on the web page.

Under Recording Optionsin the Optionsmenu make sure Record only when selected
active APT satellites are overhead is selected.Set with maximum elevation above
(degrees)to about 30 to prevent low elevation passes from being recorded and presented
on the web page. And setrecord only when satellite is above (degrees)to about 15 to
crop the noisy top and bottom sections of the image when the satellite is not high
enough to receive a good signal.

How can I present time as local time on my web pages?
If you have purchased the upgrade, openWeb Page Settings from the Record dialog
under the File menu.Click the Browse button after HTML Template and select tem-
plate2.html. Click OK, then click Accept.

If the time is also displayed on the images (text overlay), then openTe xt Options from
the Options menu.Replace UTC with %@%Z or %@local or use %@ followed by
your time zone (e.g. %@EST). SelectOK.

Can I change the web page layout, number of images, or information on the web
page?
Yes, if you have purchased the upgrade.In Web Page Settingsin Recordunder theFile
menu you will find an option for theHTML Template. This template is the HTML doc-
ument used to create the web page.You can try the other templates provided (note that
the web page will not change until after the next satellite pass).

Or you can create your own template.You may wish to look at the default (tem-
plate1.html) document as a guide.You can copy this file to another and edit it.

The web page,HTML filename, is created from theHTML Templateby substituting text
within the template.

The text imageX.jpg will be replaced with the name of an image created by WXtoImg.
thumbX.jpg will be replaced with the name of the corresponding thumbnail.X should
be a number 1 or greater. The most recent image will be useX equal to 1.You should
not leave any gaps in the image numbers.If you want 4 images on your web page then
you should have references toimage1.jpg, image2.jpg, image3.jpg, and image4.jpg and
likely the 4 corresponding thumbnails:thumb1.jpg, thumb2.jpg, thumb3.jpg, and
thumb4.jpg.

Information text about the satellite pass or ground station can also added to the web
page. INFO(X,Y) in the template will be replaced with the info corresponding to image
X (as above the most recent image is 1).Y is a number which indicates the
information desired (chosen from the list below). Therecan be no spaces in this string.
E.g. INFO(2, 4) will not be replaced.For Y=4 or Y=44 an optional extra argument can
be used which specifies the date/time format (e.g. INFO(1,44,%Y/%m/%d %H:%M
%Z)).

Y Description
0 width of image (in pixels)
1 height of image (in pixels)
2 width of thumbnail (in pixels)
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3 height of thumbnail (in pixels)
4 time of satellite pass (UTC)
44 timeof satellite pass (local time)
5 satellite name (e.g. NOAA 17)
6 maximum elevation of satellite pass
7 azimuth at maximum elevation (E or W)
8 direction of pass (northbound, southbound)
9 enhancement used (e.g. MSA)
39 full enhancement name (e.g. Multi-Spectral Analysis Enhancement)
10 groundstation location
11 latitudeof ground station
12 longitudeof ground station
13 frequency in MHz (e.g. 137.62)
14 projectionname (e.g. Mercator)
15 channelA (e.g. 3)
16 channelB (e.g. 4)
17 language(e.g. en)
18 characterset (e.g. iso-8859-1)
19 wxtoimgversion number (e.g. 2.4.15)
20 receiver (e.g. R2FX)
21 passduration (e.g. 14:59)
22 solarelevation (e.g. 23.3)
23 antennatype
24 estimatedtime of publication (UTC)
64 estimatedtime of publication (local time)

To display information about future satellite passes on your web site you can use
X=-1,-2... withX=-1 being the next satellite pass.Y=24 and Y=64 apply only to future
satellite passes. The optional date/time format argument can be used with Y=24 and
Y=64 as well as with Y=4 and Y=44.

Any of the following can be used in the optional date/time format:
%a abbreviated weekday name
%A full weekday name
%b abbreviated month name
%B full month name
%d dayof the month
%H hourusing a 24-hour clock
%I hourusing a 12-hour clock
%j dayof the year (001-365)
%m monthas a number
%M minute
%p am/pmdesignation
%S second
%y yearwithout a century
%Y yearincluding the century
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%Z timezone name or abbreviation
%% a‘%’ character

Copyright
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Upgrade
How do I upgrade?
Point your browser at:

http://www.wxtoimg.com/reg/

and follow the instructions.For a small fee you will be sent a personal upgrade key that
you can use to enable additional features.

Why should I upgrade?
Upgrading helps make continuing development possible.Additionally, by upgrading
additional features become available.

There are two upgrade editions, the Standard Edition and the Professional Edition.

What additional features are enabled when I purchase the Standard Edition *?
Anaglyph 3-D enhancements. These can provide a stunning way of viewing the cloud
layers. They must be viewed with special red/blue glasses.

Adds enhancements with (estimated) precipitation overlays. Notethat the precipitation
overlays will not function with narrow bandwidth receivers.

Improved image quality for narrow bandwith receivers (e.g. scanners, communication
receivers).

Web pages may be completely customised when you upgrade.

Enables many other projections (geographic transformations) including the Mercator
Projection along with enabling options (such as the centre or reference longitude, scale
and boundaries) for controlling the transformation of images from APT satellites.

Allows for the creation of animated movies of the images from multiple polar satellites
(moving cloud, stationary land).

Composite images can be created from multiple polar satellite passes so as to cover a
large area.

Enables image rotation cababilities along with colour shifting and grayscale conversion.

Allows a GPS (NMEA) to be used to automatically set the latitude and longitude.

Allows local time (instead of UTC time) to be displayed.

The latitude and longitude under the cursor are shown along with the distance (and
direction) from the ground station in APT images.

Information can be optionally displayed on the images in a selectable size font and
colour. This can be automated and can include the name of the satellite, time and loca-
tion of the pass along with many other details related to the satellite and image.

Tear-off menus are supported.This allows easier selection of enhancements and options
through windows which are always on screen. This option is not available on MacOS
X.

Provides support for the control of the FT-8x7, PCR100/PCR1000/PCR1500/PCR2500,
SAN 200, WRX-137, Timestep Proscan i-interface, AOR, Uniden Bearcat, ICOM, and

version 2.10.10 1



WXTOIMG(UPGRADE) WXTOIMG(UPGRADE)

Kenwood receivers and support for a user-supplied radio control program (see website
for more details).

Allows the program to be configured to automatically enter record/decode mode at the
start of a satellite pass for completely automated recording.

In addition, future work will focus on features only for users who have purchased the
standard edition.

Neither the standard edition nor the freeware edition can be used for commercial pur-
poses.

What additional features are enabled when I purchase the Professional Edition *?
The Professional Edition provides all the features of the Standard Edition, plus:

allows for an on-image temperature scale for thermal and sea surface temperature
enhancements,

provides a choice of resample algorithms (for geographic transformation),

provides additional noise filter options,

provides additional contrast options, and

provides detailed control over which sensor is used for illumination with HVCT and
HVC enhancements, and

can be used for commercial purposes.

* specifications subject to change without notice, see website for current details.

Thank You
in advance for your upgrade at:

http://www.wxtoimg.com/reg/
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